Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007667 [Squeak] Kernel minor always 09-07-11 11:26 09-08-11 14:16
Reporter FrankShearar View Status public  
Assigned To FrankShearar
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version
  Product Build
Summary 0007667: ScaledDecimal newFromNumber: 0.0 scale: 0 can't print
Description Evaluate the following:

0s0 "=> 0s0"
ScaledDecimal newFromNumber: 0 scale: 0 "=> 0s0"

0.0s0 "=> 0s0"
ScaledDecimal newFromNumber: 0.0 scale: 0 "=> MNU: SmallInteger doesn't understand printTruncatedOn:showingDecimalPlaces:"

The MNU happens because in ScaledDecimal class >> #newFromNumber:scale: we say

    "..." aNumber asFraction "..."

and when aNumber = 0.0, aNumber asFraction = 0, which is a SmallInteger and not a Fraction.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014184 - 47 - 47 - 47 - 47 - 47 - 47)
FrankShearar
09-08-11 14:16

Nicolas Cellier fixed this: Kernel-nice.614.mcz
 

- Issue History
Date Modified Username Field Change
09-07-11 11:26 FrankShearar New Issue
09-07-11 11:26 FrankShearar Status new => assigned
09-07-11 11:26 FrankShearar Assigned To  => KenCausey
09-07-11 13:36 KenCausey Assigned To KenCausey =>
09-07-11 13:36 KenCausey Status assigned => new
09-07-11 13:36 KenCausey Category Any => Kernel
09-08-11 14:16 FrankShearar Status new => resolved
09-08-11 14:16 FrankShearar Resolution open => fixed
09-08-11 14:16 FrankShearar Assigned To  => FrankShearar
09-08-11 14:16 FrankShearar Note Added: 0014184


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker