Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007682 [Squeak] Release Packaging minor always 11-23-11 10:05 12-19-12 14:21
Reporter mikevdg View Status public  
Assigned To FrankShearar
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 4.4 Product Version 4.2
  Product Build
Summary 0007682: Permissions on Squeak4.2-10966.image wrong.
Description I wanted to "install" squeak on Linux:

> cd /usr/local
> unzip ~/src/Squeak-4.2-All-in-One.zip

(as a normal user again):
> /usr/local/(squeak...)/squeak.sh

Could not open the Squeak image file `/usr/local/squeak/Contents/Resources/Squeak4.2-10966.image

> ls -l /usr/local/squeak/Contents/Resources/*

-rw-rw---- 1 root root 2132479 2011-02-05 08:07 Squeak4.2-10966.changes
-rw-rw---- 1 root root 14645656 2011-02-05 08:07 Squeak4.2-10966.image

These need read permissions for all.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014252 - 189 - 189 - 189 - 189 - 189 - 189)
FrankShearar
08-16-12 14:58

I don't know if 4.3 addressed the issue. At any rate, I'll ensure that 4.4 has the permissions right and then, since 4.2 is now a legacy version, close the issue (unless someone complains).
 
(0014268 - 44 - 44 - 44 - 44 - 44 - 44)
FrankShearar
12-19-12 14:21

4.4's release script forces +w on the files.
 

- Issue History
Date Modified Username Field Change
11-23-11 10:05 mikevdg New Issue
11-23-11 10:05 mikevdg Status new => assigned
11-23-11 10:05 mikevdg Assigned To  => RalphJohnson
08-16-12 14:57 FrankShearar Assigned To RalphJohnson => FrankShearar
08-16-12 14:58 FrankShearar Note Added: 0014252
12-19-12 14:21 FrankShearar Status assigned => closed
12-19-12 14:21 FrankShearar Note Added: 0014268
12-19-12 14:21 FrankShearar Resolution open => fixed
12-19-12 14:21 FrankShearar Fixed in Version  => 4.4


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
43 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker