Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007764 [Squeak] Traits major always 05-01-13 13:20 05-03-13 12:39
Reporter FrankShearar View Status public  
Assigned To FrankShearar
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version trunk
  Product Build
Summary 0007764: Cannot alias binary message names
Description Object subclass: MyObject
    uses: TMyTrait @ {#* -> #+}
    <etc>

upon accepting is turned into

Object subclass: MyObject
    uses: TMyTrait @ {#*->#+}
    <etc>

which does not parse (because you have a Symbol #*-> followed by rubbish; # is not valid in a Symbol without quotes).
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014351 - 169 - 169 - 169 - 169 - 169 - 169)
FrankShearar
05-02-13 09:09

This is because an Association prints in a manner that can potentially not be evaluated. In particular, if the key is a binary selector, the printed form will be broken.
 
(0014352 - 119 - 125 - 451 - 451 - 451 - 451)
FrankShearar
05-02-13 09:10

* http://source.squeak.org/inbox/Collections-fbs.516.mcz [^]
* http://source.squeak.org/inbox/CollectionsTests-fbs.203.mcz [^]
 
(0014353 - 44 - 44 - 44 - 44 - 44 - 44)
FrankShearar
05-03-13 12:39

Collections-fbs.517.mcz in Trunk fixes this.
 

- Issue History
Date Modified Username Field Change
05-01-13 13:20 FrankShearar New Issue
05-01-13 13:20 FrankShearar Status new => assigned
05-01-13 13:20 FrankShearar Assigned To  => dvf
05-01-13 13:20 FrankShearar Assigned To dvf => FrankShearar
05-01-13 13:49 FrankShearar Description Updated
05-02-13 09:09 FrankShearar Note Added: 0014351
05-02-13 09:10 FrankShearar Note Added: 0014352
05-02-13 09:10 FrankShearar Status assigned => feedback
05-03-13 12:39 FrankShearar Status feedback => resolved
05-03-13 12:39 FrankShearar Resolution open => fixed
05-03-13 12:39 FrankShearar Note Added: 0014353


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker