Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007835 [Squeak] VM major always 09-27-15 16:40 04-06-18 22:58
Reporter lewis View Status public  
Assigned To lewis
Priority normal Resolution fixed Platform
Status confirmed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version
  Product Build
Summary 0007835: vm-sound-NAS needs updates for 64 bit
Description This Unix VM sound driver has compile errors on 64-bit host, needs updates to platforms/unix/vm-sound-NAS/sqUnixSoundNAS.c

Reported by Ken Dickey on vm-dev http://lists.squeakfoundation.org/pipermail/vm-dev/2015-September/019470.html [^]
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014618 - 431 - 479 - 735 - 735 - 735 - 735)
nicolas cellier
04-06-18 22:58

I don't know if it has compile errors, but current version does pretty bad things...

line 524: static sqInt sound_RecordSamplesIntoAtLength(int buf, int startSliceIndex,
...
line 557: (char *) (buf + startSliceIndex*sliceSize),

Making a pointer out of an int hasn't been correct since maybe Kernighan and Ritchie...

https://github.com/OpenSmalltalk/opensmalltalk-vm/blob/Cog/platforms/unix/vm-sound-NAS/sqUnixSoundNAS.c [^]
 

- Issue History
Date Modified Username Field Change
09-27-15 16:40 lewis New Issue
09-27-15 16:40 lewis Status new => assigned
09-27-15 16:40 lewis Assigned To  => lewis
04-06-18 22:58 nicolas cellier Note Added: 0014618
04-06-18 22:58 nicolas cellier Status assigned => confirmed
04-06-18 22:58 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker