Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007847 [Squeak] OS-Mac crash always 02-21-16 16:50 06-12-18 20:02
Reporter comutt View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 5.0
  Product Build
Summary 0007847: Cmd+Shift+Cursor crashes Squeak
Description Squeak always crashes if Cmd+Shift+Cursor has been hit.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014599 - 186 - 186 - 186 - 186 - 186 - 186)
bp
10-14-16 15:55

I cannot reproduce it on the latest VM cog_macos32x86_squeak.cog.spur_201610132235 on macOS Sierra 10.12 (16A323). Does it still happen for you? If yes, for which VM on which OS version?
 
(0014613 - 277 - 313 - 683 - 683 - 683 - 683)
nicolas cellier
04-06-18 19:29

I presume that this may have been related to
https://github.com/OpenSmalltalk/opensmalltalk-vm/issues/141 [^]
In which case it has been resolved.

Could you retry with pre-release VM from
https://github.com/OpenSmalltalk/opensmalltalk-vm/releases/tag/201804030952 [^]
and report?
 
(0014621 - 384 - 426 - 426 - 426 - 426 - 426)
timj
06-09-18 17:59

Cannot reproduce in this configuration:
Squeak5.2alpha
latest update: #18062
Current Change Set: Unnamed1
Image format 68021 (64 bit)
Croquet Closure Cog[Spur] VM [CoInterpreterPrimitives VMMaker.oscog-eem.2401] 5.0.201806080613
Mac OS X built on Jun 9 2018 10:17:33 PDT Compiler: 4.2.1 Compatible Apple LLVM 9.1.0 (clang-902.0.39.2)
platform sources revision VM: 201806080613
 
(0014622 - 80 - 80 - 80 - 80 - 80 - 80)
nicolas cellier
06-12-18 20:02

It seems to be resolved: cannot reproduce with to date Opensmalltalk VM version.
 

- Issue History
Date Modified Username Field Change
02-21-16 16:50 comutt New Issue
10-14-16 15:55 bp Note Added: 0014599
10-14-16 15:56 bp Status new => feedback
04-06-18 19:29 nicolas cellier Note Added: 0014613
06-09-18 17:59 timj Note Added: 0014621
06-12-18 20:02 nicolas cellier Note Added: 0014622
06-12-18 20:02 nicolas cellier Status feedback => resolved
06-12-18 20:02 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
50 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker