Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007861 [Squeak] MVC major always 09-25-16 09:04 04-06-18 10:01
Reporter davidf View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version trunk
  Product Build
Summary 0007861: Can't debug
Description In an MVC project when pressing 'debug', we get the error

MessageNotUnderstood: UndefinedObject>>windowColorToUse

The error is caused by the method setDefaultBackgroundColor attempting to
send the message windowColorToUse to a nil model.

I have changed the implementation of View>>setDefaultBackgroundColor to

model == nil ifFalse:[self model windowColorToUse].

And this seems to fix the problem, as I now get the debugger window and everything appears to work as it should.

How to reproduce:

Open a new MVC project, open a workspace and do 2/0. When the notifier comes up select 'debug'.


Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014608 - 61 - 61 - 61 - 61 - 61 - 61)
nicolas cellier
04-06-18 10:00

Can't reproduce in current Squeak trunk, appeared to be fixed
 

- Issue History
Date Modified Username Field Change
09-25-16 09:04 davidf New Issue
04-06-18 10:00 nicolas cellier Note Added: 0014608
04-06-18 10:01 nicolas cellier Status new => resolved
04-06-18 10:01 nicolas cellier Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
34 total queries executed.
29 unique queries executed.
Powered by Mantis Bugtracker