Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000812 [Squeak] Any minor unable to reproduce 01-09-05 22:24 07-14-05 11:37
Reporter chris View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.8 Product Version
  Product Build
Summary 0000812: Message not understood: Text>>stamp when viewing code that includes removed methods
Description I viewed a change set that removes a method. After opening the "code" viewer from the file-list and then selecting the removed method (in the "*** removed methods***" category) this walkback appears.
Steps To Reproduce
Additional Information PseudoClass>>DoItIn:
Compiler>>evaluate:in:to:notifying:ifFail:logged:
[] in TextMorphEditor(ParagraphEditor)>>evaluateSelection {[rcvr class evaluatorClass new evaluate: self selectionAsStream in: ctxt...]}
BlockContext>>on:do:
TextMorphEditor(ParagraphEditor)>>evaluateSelection
TextMorphEditor(ParagraphEditor)>>printIt
[] in TextMorphEditor(ParagraphEditor)>>printIt: {[self printIt]}
TextMorphEditor(Controller)>>terminateAndInitializeAround:
TextMorphEditor(ParagraphEditor)>>printIt:
TextMorphEditor(ParagraphEditor)>>dispatchOnCharacter:with:
TextMorphEditor>>dispatchOnCharacter:with:
TextMorphEditor(ParagraphEditor)>>readKeyboard
TextMorphEditor>>readKeyboard
[] in TextMorphForEditView(TextMorph)>>keyStroke: {[editor readKeyboard]}
TextMorphForEditView(TextMorph)>>handleInteraction:fromEvent:
TextMorphForEditView>>handleInteraction:fromEvent:
TextMorphForEditView(TextMorph)>>keyStroke:
TextMorphForEditView>>keyStroke:
TextMorphForEditView(TextMorph)>>handleKeystroke:
KeyboardEvent>>sentTo:
TextMorphForEditView(Morph)>>handleEvent:
TextMorphForEditView(Morph)>>handleFocusEvent:
[] in HandMorph>>sendFocusEvent:to:clear: {[ActiveHand := self. ActiveEvent := anEvent. result := focusHolder han...]}
[] in PasteUpMorph>>becomeActiveDuring: {[aBlock value]}
BlockContext>>on:do:
PasteUpMorph>>becomeActiveDuring:
HandMorph>>sendFocusEvent:to:clear:
HandMorph>>sendEvent:focus:clear:
HandMorph>>sendKeyboardEvent:
HandMorph>>handleEvent:
HandMorph>>processEvents
[] in WorldState>>doOneCycleNowFor: {[:h | ActiveHand := h. h processEvents. capturingGesture := capturingGest...]}
Array(SequenceableCollection)>>do:
WorldState>>handsDo:
WorldState>>doOneCycleNowFor:
WorldState>>doOneCycleFor:
PasteUpMorph>>doOneCycle
[] in Project class>>spawnNewProcess {[[World doOneCycle. Processor yield. false] whileFalse. nil]}
[] in BlockContext>>newProcess {[self value. Processor terminateActive]}
Attached Files

- Relationships

- Notes
(0001179 - 93 - 105 - 105 - 105 - 105 - 105)
ohshima
02-25-05 02:23

I can't reproduce in my image... Do you have more specific way to reproduce it?

-- Yoshiki
 
(0001187 - 35 - 35 - 35 - 35 - 35 - 35)
ned
02-25-05 05:48

Fixed by 6553-0371removedMethFix-sw
 
(0001188 - 35 - 35 - 35 - 35 - 35 - 35)
ned
02-25-05 05:49

fixed by 6553-0371removedMethFix-sw
 
(0001790 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
07-14-05 11:37

fixed
 

- Issue History
Date Modified Username Field Change
01-09-05 22:24 chris New Issue
02-25-05 02:23 ohshima Note Added: 0001179
02-25-05 02:24 ohshima Reproducibility always => unable to reproduce
02-25-05 02:24 ohshima Status new => feedback
02-25-05 05:48 ned Note Added: 0001187
02-25-05 05:49 ned Status feedback => resolved
02-25-05 05:49 ned Fixed in Version  => 3.8
02-25-05 05:49 ned Resolution open => fixed
02-25-05 05:49 ned Assigned To  => ned
02-25-05 05:49 ned Note Added: 0001188
02-25-05 05:50 ned Assigned To ned =>
07-14-05 11:37 MarcusDenker Status resolved => closed
07-14-05 11:37 MarcusDenker Note Added: 0001790


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
54 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker