Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000850 [Squeak] Morphic minor always 01-29-05 01:03 07-28-05 08:51
Reporter hitoro View Status public  
Assigned To laza
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.8
  Product Build
Summary 0000850: [BUG][FIX] PostScript output is invalid
Description PostScript interpreters (Mac OS X 10.3 built-in interpreter and PStill) report problems when trying to convert a morph exported as a PostScript file. This error only occurs with 3.8 and 3.9, no problem with 3.7.

It seems that the coordinates are wrangled during export:

%%BoundingBox: $1$8 $1$8 $5$7$6 $7$5$6

The correct line should be:

%%BoundingBox: 18 18 576 756
Steps To Reproduce
Additional Information Modifying the 'ByteEncoder>>writeNumber:base:' instance method to encode numbers as strings and not as bytes solves this issue:

ByteEncoder>>writeNumber:aNumber base:aBase
    ^aNumber printOn:self base:aBase.

Attached Files  FixPostscriptByteEncoding.1.cs [^] (240 bytes) 01-29-05 01:03
 IntegerByteEncodeFix-850-v1-laza.1.cs [^] (3,654 bytes) 01-30-05 15:40

- Relationships

- Notes
(0001112 - 414 - 444 - 444 - 444 - 444 - 444)
laza
01-30-05 15:38

Hi Hitoro!

One of my changesets, which was accepted for the update stream (6217), is the source of the problem. I included some tests with it to make sure I don't brake anything important, but the tests used a Stream on String instead of ByteEncoder. I upload a fix for this and some adapted tests.
The Postscript output seems to be ok now, but I haven't tested this with an external postscript viewer.

Alex
 
(0001116 - 75 - 75 - 75 - 75 - 75 - 75)
hitoro
01-31-05 01:20

Thanks Alex. I filed in your change set in a clean 3.8g image and it works.
 
(0002006 - 7 - 7 - 7 - 7 - 7 - 7)
MarcusDenker
07-28-05 08:50

in 3.9a
 

- Issue History
Date Modified Username Field Change
01-29-05 01:03 hitoro New Issue
01-29-05 01:03 hitoro File Added: FixPostscriptByteEncoding.1.cs
01-29-05 01:06 hitoro Issue Monitored: hitoro
01-30-05 15:38 laza Note Added: 0001112
01-30-05 15:40 laza File Added: IntegerByteEncodeFix-850-v1-laza.1.cs
01-30-05 15:41 laza Status new => assigned
01-30-05 15:41 laza Assigned To  => laza
01-30-05 15:43 laza Status assigned => feedback
01-31-05 01:20 hitoro Note Added: 0001116
01-31-05 02:27 laza Status feedback => resolved
01-31-05 02:27 laza Resolution open => fixed
02-04-05 09:41 hitoro Issue End Monitor: hitoro
07-28-05 08:50 MarcusDenker Status resolved => closed
07-28-05 08:50 MarcusDenker Note Added: 0002006
07-28-05 08:51 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
56 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker