Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000086 [tweak] minor always 08-19-04 21:37 09-23-04 17:53
Reporter tedka View Status public  
Assigned To bert
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Product Build
Summary 0000086: Positioning an object -- new methods needed
Description Problem: You are deep in a structure of nested objects on the screen. You want to pop up a new object zz, exactly over some deep object mm. When you say (zz position: pt), what should pt be?
Yes, you can compute (mm globalBounds origin) - (mm world project origin), but there really needs to be a name for this quantity.
The position of the new object will be relative to the CProject. CPlayers don't respond to #project. Shall I define it?
There is a message #globalPosition, but it is not defined in CPrimitiveConstume, and gives an error. (Shall I define it?) #globalPosition is probably intended to give the position relative to World, and that is not what we want.
Any ideas about how to make this much easier?
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0000171 - 103 - 103 - 103 - 103 - 103 - 103)
bert
09-23-04 17:53

Fixed by update 164. Position of any new object is in global coordinates, not offset by project origin.
 

- Issue History
Date Modified Username Field Change
08-19-04 21:37 tedka New Issue
09-23-04 17:53 bert Status new => resolved
09-23-04 17:53 bert Resolution open => fixed
09-23-04 17:53 bert Assigned To  => bert
09-23-04 17:53 bert Note Added: 0000171


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
35 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker