Mantis - tweak
Viewing Issue Advanced Details
2385 Any block always 12-19-05 21:40 02-24-06 22:58
hitoro  
 
normal  
new  
open  
none    
none  
0002385: Dead modifier keys with AZERTY keyboard and latest versions of the Mac VM (3.8.7Beta7 and over)
I have an AZERTY keyboard and I can't use any keystroke requiring a modifier key. For example, typing Command-a in a text editor does nothing. Typing Option-( to get a curly brace doesn't work either.

I have checked the keyboard event and it seems that the character is always returned as an empty string ('') and the code of the modifier key is not valid.

I have tried Squeak VM 3.7.5Beta3 and while the command key is working correctly, the use of the modifier key to get a special character is not handled correctly. For example, if I type Option-(, the keyboard event contains the character {, which is the expected character, but since the Option key is pressed, the event is considered as a editing event and not as a keystroke to get a character, thus the event gets lost.

Notes
(0004075)
hitoro   
02-24-06 22:58   
Problem solved with Tweak-Widgets-bf.135