Mantis - Squeak
|Viewing Issue Advanced Details|
|ID:||Category:||Severity:||Reproducibility:||Date Submitted:||Last Update:|
|2689||Kernel||minor||N/A||02-08-06 03:02||02-08-06 19:06|
|ETA:||none||Fixed in Version:|
|Summary:||0002689: isComplex method name is bad|
Object isComplex and Complex isComplex are both implemented in term of isKindOf: Complex.
Some other class do implement isComplex, and obviously they are complex (complicated) but not KindOf: Complex.
This can foolish some code.
|Steps To Reproduce:|
I suggest Complex being renamed ComplexNumber and isComplex being renamed isComplexNumber (see how Object>>isComplex comment claims for that).
Then any class will be free to express its complexity via isComplex without harming.
|There are no notes attached to this issue.|