Mantis - Squeak Packages
Viewing Issue Advanced Details
318 StarBrowser feature have not tried 10-08-04 23:52 02-20-07 16:45
MarcusDenker  
ned  
normal  
assigned  
open  
none    
none  
0000318: StarBrowser won't install in 3.7 from SqueakMap
Subject: [BUG]SBKomServices, StarBrowser won't install in 3.7 from SqueakMap
Author: Darius
Date Posted: 9 September 2004
Archive ID: 24240
Comments: SBKomServices, StarBrowser won't install in 3.7 from SqueakMap
On Windows XP with SP2:

For StarBrowser I get methodsFor:stamp: as invalid object.
KomPackageBuilder, SBKomServices just won't install. Fails on package load.


Notes
(0001619)
simon   
06-13-05 01:20   
Same with 3.8. SBSqueakMap.st depends on the SMCard class which no longer exists.
(0001620)
simon   
06-13-05 01:27   
Workaround: to load StarBrowser in 3.8, create a dummy SMCard class.
(0010025)
dao   
02-20-07 16:45   
I've hit this too. From reading of http://www.prism.gatech.edu/~gtg590q/squeak/SMBase-domain-SMPackage.html [^] and poking around SqueakMap classes - it seems that SMCard now is called SMPackage.

So, when DNU popups, find the reference to the 'SMCard' on the stack and rename it to 'SMPackage' right in the debugger window. Then click the 'restart' button and you should be able to add SqueakMap categories into SB tree.
(the correct fix is to adjust SB package obviously)