Mantis - Squeak
Viewing Issue Advanced Details
6555 VM minor always 07-07-07 06:37 09-05-09 18:02
matthewf  
lewis  
normal  
assigned 3.9  
open  
none    
none  
0006555: InterpreterSimulator raises MNU due to 3.9 refactorings
InterpreterSimulator>>primitiveGetAttribute uses Smalltalk rather than "SmalltalkImage current"
InterpreterSimulator>>reverseBytesFrom:to: uses Bitmap>>swapBytesFrom:to: rather than "Bitmap class>>swapBytesIn:from:to:"

attached is a changeset that makes the simulator work for the image I tried. This was tested on squeak-dev version sq3.9-7067dev07.6.2 with VMMaker 3.8b6 from squeak-dev universe.
related to 0006740closed lewis InterpreterSImulator - sqFile:Read:Into:At: has a nil file argument which causes it to blow up 
child of 0006671closed tim Build VMMaker for 3.9 
 InterpreterSimulator-3.9-fixes.1.cs [^] (1,042 bytes) 07-07-07 06:37
 InterpreterSimulator-fixes.1.cs [^] (8,254 bytes) 07-22-07 23:29
 InterpreterSimulatorFixes-al.1.cs [^] (10,382 bytes) 07-23-07 08:42
 InterpreterSimulator-fixes-mtf.1.cs [^] (10,244 bytes) 07-25-07 01:34

Notes
(0010860)
KenCausey   
07-07-07 18:00   
Assigning this issue to Tim after having assigned the VM category to him.

Tim: You are welcome to complain if you disagree with this assignment, but I would appreciate it if you would nominate another victim if you choose to complain. ;)
(0010915)
matthewf   
07-22-07 23:28   
Added a bit more fixes in InterpreterSimulator-fixes.1.cs. I was previously simulating a spoon image, this is able to simulate a 3.10 alpha 7121 image from within a 7121 image. I don't think mouse events work yet
(0010917)
al   
07-23-07 08:49   
Notes to InterpreterSimulatorFixes-al.1cs:
- Changes have been applied to image from http://www.squeakvm.org/unix/release/ [^] (version unix-3.9-10.*). Not sure if this workes for VMMaker 3.8b6 on SM. I have not tested it yet.
- there is one ugly workaround for a problem of which I couldn't find the root cause: BalloonEngineBase>>spanStartGet and >>spanEndGet. This should be looked at by somebody that knows this code before being integrated.
- Known problem: menu items are often not visible, but menu is functional
(0010934)
matthewf   
07-25-07 01:42   
incorperated all of al's changes that did not involve interpreterProxy or hex:
- hex is available in 3.10 images
- in VMMaker-3.8b1 at least, there was an unused class InterpreterSimulationObject with all the methods (cCoerce, long32at:, etc) properly implemented, and InterpreterSimulatorObject has no references or instances. I removed that class after moving all it's methods into InterpreterSimulator, and my simulator seems to work all right.

al: I did not yet try your fix in whole, but with the part I did try, mouse events still don't seem to be propogating in my setup (3.10-alpha-7121 master, 3.10-alpha-7121 slave, VMMaker-3.8b6). I clicked and waited 5 minutes, but no World Menu showed up. How long does it take with your setup
(0010935)
al   
07-25-07 07:16   
to open the world menu it takes maybe 10 seconds. However, sometimes it seems that not all mouse clicks are processed. For example, selecting a menu item did not work properly, but hitting enter on the keyboard did.
(0011411)
matthewf   
11-01-07 01:26   
Rob Withers tried building a vm with the patches InterpreterSimulator-mtf.1.cs applied, and there was an infinite recursion:

http://lists.squeakfoundation.org/pipermail/vm-dev/2007-November/001647.html [^]