Mantis - Squeak
Viewing Issue Advanced Details
6631 Squeak 64 bit crash always 08-21-07 09:24 04-18-10 22:06
Friedrich  
lewis  
normal  
closed 3.9  
fixed  
none    
none  
0006631: crash while connecting to SqueakMap
every time I use the SqueakMap Package Loader the system crashes. I downloaded th e newest sources from the SVN tree and compiled the stuff myself here:
the crash has the following traceback:
frido@flarge:~LD_LIBRARY_PATH% ./squeak ../Squeak3.9-final-7067.image

Segmentation fault

24103744 [] in >addressForName:timeout:
24103836 [] in Semaphore>critical:
24103468 BlockContext>ensure:
24103376 Semaphore>critical:
24102608 >addressForName:timeout:
24100496 >httpGetDocument:args:accept:request:
24100404 >httpGet:args:accept:request:
24100252 >httpGet:args:accept:
24099792 >httpGet:accept:
24099700 >httpGet:
24100068 [] in >pingServer:
24099516 BlockContext>on:do:
24099424 >pingServer:
24099976 [] in >findServer


duplicate of 0005688closed tim VM crash due to SmartSyntaxPluginCodeGenerator>>generateCPtrAsOop:indent: 

Notes
(0011045)
user709   
08-21-07 10:15   
Ok, I downlaoded another image the final 3.9 image and whith that the connection works. So I guess it's a problem having checked out the last svn stuff which might not work.

Regards
Friedrich
(0011046)
user709   
08-21-07 10:43   
I tried to spot the problem and now I can tell.
with a 32-bit squeak I can download the things from the map
with a 64-bit squeak the crash happens usually.

So it's seems to be related to some 64-bit issues.

sorry that I can not be of more help...

Regards
Friedrich
(0011351)
user709   
10-18-07 11:49   
Ok I downloaded squeak from the subversion tree again. And I installed also the 32-bit version again. I can connet with the 32-bit squeak but if I use the same image with the 64-bit version I got:
Segmentation fault

21731576 [] in >addressForName:timeout:
21731668 [] in Semaphore>critical:
21731300 BlockContext>ensure:
21731208 Semaphore>critical:
21730440 >addressForName:timeout:
21727552 >httpGetDocument:args:accept:request:
21653892 HttpUrl>retrieveContentsArgs:accept:


The problem still persists. Does anyone have an idea why that is happening?

Regards
Friedrich
(0013025)
lewis   
03-08-09 13:46   
The original "dist3" sources are quite out of date. Use the latest Subversion sources and the latest VMMaker from SqueakSource, then apply the fix in Mantis 5238. This will resolve the problem reported here. You will also need an updated 64-bit image to use with this VM (contact lewis at mail dot msen dot com if you do not have this).
(0013027)
lewis   
03-08-09 13:47   
Resolved in Mantis 5688