Mantis - Squeak
Viewing Issue Advanced Details
7498 VM block sometimes 04-09-10 19:14 04-09-10 19:16
wiz  
lewis  
normal  
assigned trunk  
open  
none    
none  
0007498: In Sq 9885 on Ubuntu doing Beeper beep latches the cpu usage to 100%
This is a strange one.

I have several images and vms on my machine.
I use the gnome lauchers to launch them directly and the -plugin option to point to a plugin directory

The 4.1 release cadidate 2 (sq 9885) is launched with
'myDir/bin/squeak'
-plugins 'myDir/lib/squeak/3.11.3-2135'
'/home/hubuntu/Sq9885b.image'

using the 3.11.3-2135 vm as indicated by the distribution.

That said once lauched the cpu usage is normal until the first time I use sound.

In a fresh sq 9885
Open a workspace.
Type "Beeper beep"
Doit.
Note the sound plays.

But after I do that once:
The cpu monitor indicates the squeakvm is hogging the cpu usage (>90%)
along with the pulseaudio

Next type alt-. (i.e. stop interupt.)
Cpu usage goes back to normal.


I have tried the test in my 3.9 squeak with the older vm and this does not happen there.

I have tried it with a sq 9926 (3.11 updated) using pharo-vm-0.15.1b-linux and a Alsa plugin from the etoys distro. I can get the sound w/o the cpu latch up.

So this seems tied to the vm and plugings in 3.11.3-2135 vm distribution.

It seems to involve locking up the sound resource. Other programs trying to use sound sometimes seem to go haywire after squeak has triped the condition.

Does this happen on other system configurations?

Does it happen if the release candidate is run with other vm's?

Are there other vm's for linux for this distribution other than the one I found?

Yours in curiosity and service, --Jerome Peace




Notes
(0013677)
wiz   
04-09-10 19:16   
I have marked this as sometimes reproducable because other programs using the sound resource can interact with the problem. Mostly if all else is quiet this can be reliably reproduced.

Cheers --Jer