Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001015 [Squeak] Morphic tweak always 03-25-05 05:29 02-15-06 18:58
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0001015: [Goodie] SnapView provides clean screen shots and snapshot images of morphs.
Description I added an ability to the light blue view handle. If you hold the shift down you will get the exact image of the morph as an image morph.
If you have tilted the morph the image will be of the tilted morph.

To distinguish the snap from the real morph there is a slight border added to the snapshot. This can be changed or eliminated if desired.
Additional Information This is the same goodie that I published to squeak dev before. I had to change the handle that is was connected to because the dup handle now uses the shift function for something else (as of 3.8).

The added advantage of view handle is that all handles are removed before the snap is taken and so a world snapView is the equivalent of a clean screen shot.
Attached Files  SnapView-wiz.1.cs.gz [^] (836 bytes) 03-25-05 05:30
 TileHandleEnh-wiz.1.cs [^] (2,119 bytes) 01-02-06 14:50

- Relationships

- Notes
(0003418 - 1151 - 1288 - 1288 - 1288 - 1288 - 1288)
wiz
01-02-06 14:59

I've upload TileHandleEnh-wiz.1.cs to fix something I overlooked when I moved snapview to the view halo handle.



From the cs preamble:

When I wrote SnapView, I missed the fact that sw (Scott Wallace I believe) had 'temporarily' appropriated the shifted view handle to pop up an instance browser with handles.

Snapviews hook over rode sw's hook because of where I had placed it. Also openViewerForArgument had several other senders and so should not have been the place to check for a shift key distinction.

My solution was to move sw's shift function to the tear-off-a-tile handle instead.

My reasons for choosing this solution are:
1) The eye symbol on the view handle is evocative of my snap shot function.
2) the instanceBrowserWithTiles fits in with the theme of the tile handle.
3) the hook for sw's shift key was in the wrong place and made the code awkward and because of the other senders to that method possible incorrect.



If anyone thinks it should be the other way around I'm willing to negotiate. I think this is a good resolution for now.
"!

With this addition everything is ready to go into the image.
 
(0003868 - 560 - 644 - 644 - 644 - 644 - 644)
MarcusDenker
02-15-06 18:58

Name: MorphicExtras-jmv.9
Author: jmv
Time: 12 January 2006, 1:33:41 pm
UUID: 2720167c-765e-9541-8f14-dd3789d8fca8
Ancestors: MorphicExtras-CdG.7


Mantis-0503-TargetSighting, fix by Jerome Peace (wiz)
Mantis-1015-SnapView, fix by Jerome Peace (wiz)
Mantis-1771-ClickExerciser, fix by Jerome Peace (wiz)
Mantis-1625-Thumbnails, fix by Jerome Peace (wiz)
Mantis-1484-TrashHalo, fix by Jerome Peace (wiz)
Mantis-1454-ArrowPrototypeFix, fix by Jerome Peace (wiz)
Mantis-1347-ListDoubleClick, fix by Jerome Peace (wiz)
Reviewed by Juan Vuletich (jmv)
 

- Issue History
Date Modified Username Field Change
03-25-05 05:29 wiz New Issue
03-25-05 05:30 wiz File Added: SnapView-wiz.1.cs.gz
03-25-05 20:21 KenCausey Category Any => Morphic
01-02-06 14:50 wiz File Added: TileHandleEnh-wiz.1.cs
01-02-06 14:59 wiz Note Added: 0003418
02-15-06 18:58 MarcusDenker Status new => closed
02-15-06 18:58 MarcusDenker Note Added: 0003868
02-15-06 18:58 MarcusDenker Resolution open => fixed
02-15-06 18:58 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker