Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001065 [Squeak] System major always 04-12-05 06:52 09-30-13 23:18
Reporter Larry Trutter View Status public  
Assigned To tim
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0001065: [MC] [BUG] MCScanner and Squeak 3.8
Description As reported by Pavel Krivanek <squeak1@continentalbrno.cz>:
MCScanner fails when it loads version info which contains MultiString (with
national specific characters) instead of classic String.

Sample package included.

-- Pavel
Additional Information Able to duplicate the error in 3.8g-6643
Attached Files  MCBug-pk.1.mcz [^] (743 bytes) 04-12-05 06:52
 Monticello-m17n-patch.4.cs [^] (1,104 bytes) 01-09-06 11:34
 Monticello-m17n-patch.5.cs [^] (1,211 bytes) 02-05-06 14:13

- Relationships
related to 0001671closed  Monticello cannot produce a correct mcz file when its sources include unicode strings. 

- Notes
(0002790 - 566 - 596 - 596 - 596 - 596 - 596)
Krivanek
10-07-05 08:34

Itís the following problem: Monticello saves version info in a file in zip archive. It reads content of this file and parses it (MCMczReader>>parseMember:). It works well until the version info contains a WideString. Then the version string is still interpreted as ByteString so the parsing fails.

We have to guess if the source ByteArray contains simple ByteString or WideString. But thatís not all. The version info contains UUIDs that are stored as simple ByteStrings. So result is mix of ByteString and WideString!

I suggest to store version info as UTF-8.
 
(0002823 - 27 - 27 - 27 - 27 - 27 - 27)
umejava
10-11-05 06:47

Is this related to 0001671?
 
(0002826 - 50 - 50 - 50 - 50 - 50 - 50)
Krivanek
10-11-05 10:37

Yes. Well done! 0001671 and 0001065 may be closed.
 
(0003438 - 244 - 244 - 244 - 244 - 244 - 244)
umejava
01-09-06 11:34

Try the Monticello-m17n-patch.4.cs. You can read m17n MCZ, MCD files. Note that MCBug-pk.1.mcz file is already corrupt (because part of the problem is in MCMczWriter, not Reader). You can create new MCZ, MCD files and confirm they can be read.
 
(0003705 - 65 - 65 - 65 - 65 - 65 - 65)
umejava
02-05-06 14:13

New slightly changed patch (Monticello-m17n-patch.5.cs) attached.
 
(0014460 - 13 - 13 - 13 - 13 - 13 - 13)
tim
09-30-13 23:17

Fixed in 1671
 

- Issue History
Date Modified Username Field Change
04-12-05 06:52 Larry Trutter New Issue
04-12-05 06:52 Larry Trutter File Added: MCBug-pk.1.mcz
10-07-05 08:34 Krivanek Note Added: 0002790
10-11-05 06:47 umejava Note Added: 0002823
10-11-05 10:37 Krivanek Note Added: 0002826
01-09-06 11:34 umejava File Added: Monticello-m17n-patch.4.cs
01-09-06 11:34 umejava Note Added: 0003438
01-11-06 09:21 pmm Issue Monitored: pmm
01-15-06 10:23 MarcusDenker Relationship added related to 0001671
02-05-06 14:13 umejava File Added: Monticello-m17n-patch.5.cs
02-05-06 14:13 umejava Note Added: 0003705
09-30-13 23:17 tim Status new => resolved
09-30-13 23:17 tim Fixed in Version  => 3.9
09-30-13 23:17 tim Resolution open => fixed
09-30-13 23:17 tim Assigned To  => tim
09-30-13 23:17 tim Note Added: 0014460
09-30-13 23:18 tim Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
74 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker