Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001123 [tweak] Any minor always 04-27-05 17:37 06-04-05 08:39
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001123: root is not always world
Description there are several implementors of #root in the CPlayer hierarchy, leading to inconsistencies. Like, when inspecting new rectangle player:

self root "World"
self container "Project"
self container root "Project"
self container container "ProjectBuilder"
self container container root "World"

This is because CProject implements #root, but the lookup in its elements is via its costume, bypassing the project itself.

Other players accidentally redefine root, such as CTreeWidget.
Additional Information
Attached Files

- Relationships

- Notes
(0001583 - 58 - 58 - 58 - 58 - 58 - 58)
andreas
06-04-05 08:39

No longer relevant with the project architecture in place.
 

- Issue History
Date Modified Username Field Change
04-27-05 17:37 bert New Issue
06-04-05 08:39 andreas Status new => resolved
06-04-05 08:39 andreas Resolution open => fixed
06-04-05 08:39 andreas Assigned To  => andreas
06-04-05 08:39 andreas Note Added: 0001583
06-04-05 08:39 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker