Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001223 [tweak] Any minor always 05-18-05 13:18 05-19-05 17:16
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001223: Debugging secondary bugs
Description I just had an "interesting" bug. It popped up *two* debuggers - one in Tweak, and one in Morphic.

The first was a genuine keyNotFound error in a setupCostume method. This prevented the player from opening fully. However, a geometryChanged event was already triggered, and the handler for that accessed the bounds of the player's container which was still nil, since the opening did not succeed. Thus, the second error was a "MNU: UndefinedObject>>bounds".

The odd thing is that the second error did not just pop up another Tweak debugger, but (through the ErrorRecursion logic) brought up a Morphic debugger on the Tweak debugger (rather than on the guilty context). I had to manually print the stack of aContext in there to find out what was actually going on.

I think that the error recursion logic would have to be made more selective, because a second error that was *not* caused by opening the Tweak debugger should indeed bring up another Tweak debugger. Only if opening the debugger itself fails than we should fall back to whatever other means we have.
Additional Information
Attached Files  debugger-bf.1.cs.gz [^] (899 bytes) 05-18-05 16:22

- Relationships

- Notes
(0001504 - 160 - 160 - 160 - 160 - 160 - 160)
bert
05-18-05 16:23

Uploaded proposed fix: This marks the debugger process, and invokes the primitiveError handler only if an error occured in that process, or one triggered by it.
 
(0001506 - 74 - 74 - 74 - 74 - 74 - 74)
bert
05-19-05 17:16

fixed by marking the debugger process, although not the ones spawned by it
 

- Issue History
Date Modified Username Field Change
05-18-05 13:18 bert New Issue
05-18-05 16:22 bert File Added: debugger-bf.1.cs.gz
05-18-05 16:23 bert Note Added: 0001504
05-19-05 17:16 bert Status new => resolved
05-19-05 17:16 bert Resolution open => fixed
05-19-05 17:16 bert Assigned To  => bert
05-19-05 17:16 bert Note Added: 0001506
05-19-05 17:16 bert Assigned To bert =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
41 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker