Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001228 [tweak] Any minor always 05-19-05 18:00 05-29-05 10:08
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001228: trash can added to itself
Description when deleting the trash can, and then opening a new one, the old one is found in the new trash. Also, dragging the trash can into the open trash viewer creates a copy.
Additional Information
Attached Files

- Relationships

- Notes
(0001507 - 558 - 588 - 588 - 588 - 588 - 588)
ScottWallace
05-19-05 22:21

Are these really bugs? To me they'r nothing more than the consequences of simple consistency... Think of a "trashcan" icon as an *alias* to the "great trash-bin in the sky". Like any alias (on the Mac, e.g.) you can have many of them, and you can throw them away, move them from place to place, etc., but such actions only affect the alias, not the abstract "trash". When you dismiss a trash-can, what you're throwing away is the *alias*, not the cosmic trash itself. Perhaps this is too esoteric, but it seems to me to be well-defined and consistent...
 
(0001509 - 682 - 704 - 704 - 704 - 704 - 704)
bert
05-20-05 01:28

Well, what really should happen IMHO is that the trashcan icon "morphs" into the trashcan view, that is, it disappears. I know that is not what the Mac does, but neither can you drag the Mac's trashcan into the trash folder view.

Aliases are a strange thing to many people (don't even really exist on Windows), and in fact, every other object we drag to the trash *is* deleted from the world, so it looks like the object itself was moved to the trash. I'd even argue that deleting the trashcan should empty the trash. If we introduce aliases at all (in violation of the one object == one view principle), then aliases should be clearly designated as such. They are in the Mac UI.
 
(0001544 - 53 - 53 - 53 - 53 - 53 - 53)
andreas
05-29-05 10:08

For now, trash cans are no longer added to the trash.
 

- Issue History
Date Modified Username Field Change
05-19-05 18:00 bert New Issue
05-19-05 22:21 ScottWallace Note Added: 0001507
05-20-05 01:28 bert Note Added: 0001509
05-29-05 10:08 andreas Status new => resolved
05-29-05 10:08 andreas Resolution open => fixed
05-29-05 10:08 andreas Assigned To  => andreas
05-29-05 10:08 andreas Note Added: 0001544
05-29-05 10:08 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker