Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001230 [tweak] Any minor always 05-19-05 19:22 05-24-05 02:52
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001230: CDebugger instances not garbage collected
Description ... because they're held in the TestingScriptRegistry, there is a #startScript: call on its class side
Additional Information
Attached Files

- Relationships

- Notes
(0001512 - 294 - 294 - 294 - 294 - 294 - 294)
andreas
05-22-05 20:59

It's CDebugger *class* not instances of CDebugger which get held in that script registry. What's more important is that after the debugger is opened the script is removed and therefore the (weak) key eligible for garbage collection. In other words: everything is just the way it ought to be ;-)
 
(0001515 - 468 - 468 - 468 - 545 - 545 - 545)
bert
05-23-05 00:05

Actually, what I meant is what I wrote, instances of CDebugger were held by the scripts, though indirectly, there were four scripts still held by the class entry in the script registry even after Tweak was closed and a full garbage collect. Now you're right that I should have investigated further because those weak links could not have been the sole reference to the scripts, right? Maybe the script was not removed because I was debugging the debugger (cf. 0001223).
 
(0001519 - 94 - 94 - 94 - 94 - 94 - 94)
andreas
05-24-05 02:52

I've made these startScripts happen on instances now so TestingScriptRegistry will stay clean.
 

- Issue History
Date Modified Username Field Change
05-19-05 19:22 bert New Issue
05-22-05 20:59 andreas Status new => resolved
05-22-05 20:59 andreas Resolution open => no change required
05-22-05 20:59 andreas Assigned To  => andreas
05-22-05 20:59 andreas Note Added: 0001512
05-22-05 20:59 andreas Assigned To andreas =>
05-23-05 00:05 bert Status resolved => feedback
05-23-05 00:05 bert Resolution no change required => reopened
05-23-05 00:05 bert Note Added: 0001515
05-24-05 02:52 andreas Status feedback => resolved
05-24-05 02:52 andreas Resolution reopened => fixed
05-24-05 02:52 andreas Assigned To  => andreas
05-24-05 02:52 andreas Note Added: 0001519
05-24-05 02:52 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
51 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker