Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001233 [tweak] Any minor always 05-23-05 12:03 05-24-05 22:29
Reporter jens View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001233: CDropDownList ignores itemMaker
Description CDropDownList does not use itemMaker for creation of item costumes
like CList does it.

Additional Information
Attached Files

- Relationships

- Notes
(0001516 - 137 - 137 - 137 - 137 - 137 - 137)
jens
05-23-05 12:39

This happens because the list in the CDropDownList is a CMenu, whichs itmes are only strings, (and not generated CListItems as expected).
 
(0001517 - 137 - 137 - 137 - 137 - 137 - 137)
jens
05-23-05 12:40

This happens because the list in the CDropDownList is a CMenu, whichs itmes are only strings, (and not generated CListItems as expected).
 
(0001522 - 302 - 302 - 302 - 302 - 302 - 302)
andreas
05-24-05 02:57

Good point. I am not sure this will be fixed any time soon. If you have a fix for it yourself please attach it to the bug so I can look at it and integrate if appropriate. (the best way to do this is to copy CDropDownListCostume and fix it in the copy so that we don't need to patch any existing guys).
 
(0001525 - 443 - 503 - 815 - 815 - 815 - 815)
jens
05-24-05 19:02

I made a CPopUpListCostume for CDropDownList which is a Chooser and not a combo box. It also has uses an itemMaker mechanism.

sample code looks like this:
l := CDropDownList new.
l items := CCollection withAll: StrikeFont actualFamilyNames.
l itemMaker := CListMenuFontItem.
l costume := CPopUpListCostume.
l openInHand.

http://source.impara.de/Stuff/Tweak-Widgets-jl.68.mcz [^]
http://source.impara.de/Stuff/Tweak-Costume-jl.41.mcz [^]
 
(0001526 - 235 - 235 - 235 - 235 - 235 - 235)
andreas
05-24-05 22:28

Thanks, I've integrated the changes. One note: If you ever again feel that you need to use syncScript it's probably the symptom of some bug. In this case it was an oddity in CLabelCostume which caused the items not to show up properly.
 

- Issue History
Date Modified Username Field Change
05-23-05 12:03 jens New Issue
05-23-05 12:39 jens Note Added: 0001516
05-23-05 12:40 jens Note Added: 0001517
05-24-05 02:57 andreas Note Added: 0001522
05-24-05 02:57 andreas Status new => acknowledged
05-24-05 19:02 jens Note Added: 0001525
05-24-05 22:28 andreas Status acknowledged => resolved
05-24-05 22:28 andreas Resolution open => fixed
05-24-05 22:28 andreas Assigned To  => andreas
05-24-05 22:28 andreas Note Added: 0001526
05-24-05 22:29 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker