Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001306 [tweak] Any minor always 06-04-05 03:58 06-04-05 04:40
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001306: CProjectMorph bootstrapping
Description I tried to add a ticking method to CProjectBuilder but it never gets executed when run in CProjectMorph. Inspecting the builder's scripts reveals the TickMessageSend's process is nil. This is the method I wanted to have (for debugging, we're seeing way too many full GCs).

indicateGC
    | gcCount lastCount |
    <ticking: 1>
    gcCount _ SmalltalkImage current vmParameterAt: 7.
    (lastCount _ self propertyValueAt: #gcCount) ~= gcCount ifTrue: [
        lastCount ifNotNil:
            [lastCount+1 to: gcCount do: [:i |
                (PluckedSound pitch: 2000 dur: 0.2 loudness: 0.1) play.
                self wait: 0.5]].
        self propertyValueAt: #gcCount put: gcCount.
    ].
Additional Information
Attached Files

- Relationships

- Notes
(0001579 - 147 - 147 - 147 - 147 - 147 - 147)
andreas
06-04-05 04:40

Interesting bug. Turns out worlds were never informed that they appeared in a world and thusly the ticking scripts were never activated. Now fixed.
 

- Issue History
Date Modified Username Field Change
06-04-05 03:58 bert New Issue
06-04-05 04:40 andreas Status new => resolved
06-04-05 04:40 andreas Resolution open => fixed
06-04-05 04:40 andreas Assigned To  => andreas
06-04-05 04:40 andreas Note Added: 0001579
06-04-05 04:40 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker