Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001367 [tweak] Any minor always 06-22-05 16:55 06-22-05 21:17
Reporter jens View Status public  
Assigned To
Priority normal Resolution fixed  
Status resolved  
Summary 0001367: copying textHolder is broken
Description a) Copying textHolder from a Player to a Player:

 p := CPlayer open.
 p text := 'hallo'.
 p2 := CPlayer open.
 p2 text := 'foo'.
 p2 textHolder := p textHolder

p2 does not display 'hallo' until for example extent changed'

b) copying textHolder form a Player to an Editor

 p := CPlayer open.
 p text := 'hallo'.
 e := CTextEditor open.
 e text := 'bla'.
 e textHolder := p textHolder.

e does not display 'hallo' until for example extent changed'
and after that, 'bla' and 'hallo' are shown at the same time
and 'bla' is editable.




Additional Information
Attached Files

- Relationships

- Notes
(0001672 - 700 - 780 - 780 - 780 - 780 - 780)
andreas
06-22-05 21:17

I fixed the cause of the first problem but *not* the second one since it is unclear to me whether accessing the text editor's textHolder that way should be allowed or not. To make the second version work (well, sort of - there are some other issues with it) simply delegate the textHolder messages to the target, e.g.,

CTextEditor>>textHolder
  ^target textHolder

CTextEditor>>textHolder: aTextHolder
  ^target textHolder: aTextHolder

I am curious what you need this for, though. I *might* be convinced to add this to CTextEditor in general but I'd like to find out why you think you need it (after all, this might just be a little diversion that may not survive more than a week or so ;-)
 

- Issue History
Date Modified Username Field Change
06-22-05 16:55 jens New Issue
06-22-05 21:17 andreas Status new => resolved
06-22-05 21:17 andreas Resolution open => fixed
06-22-05 21:17 andreas Assigned To  => andreas
06-22-05 21:17 andreas Note Added: 0001672
06-22-05 21:17 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker