Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001430 [Squeak] MVC minor always 07-08-05 00:33 04-18-10 21:51
Reporter gokr View Status public  
Assigned To laza
Priority normal Resolution unable to reproduce  
Status closed   Product Version 3.8
Summary 0001430: [BUG]Flaps disappearing when creating MVC project (version 3.8-6665)
Description When I create an MVC project the shared flaps disappear. But I can show
them again.
Not sure why they disappear. Tracked it down to
Project>>flapsSuppressed: being called from
#initializeProjectPreferences. I can't say that I follow the logic.

First of all, why does it change the Preference? Shouldn't it only touch
the project preference?
And secondly, why does it remove/add the flaps to the screen if the
Project is NOT the current project? Shouldn't it be the other way
around?

Confused.
Additional Information
Attached Files

- Relationships
child of 0007212new  Mother for flaptab issues 

- Notes
(0001717 - 1000 - 2366 - 2366 - 2366 - 2366 - 2366)
masm
07-08-05 00:35

In fact, with this version:

flapsSuppressed: aBoolean
    "Make the setting of the flag that governs whether global flaps are
suppressed in the project be as indicated and add or remove the actual
flaps"

    self projectPreferenceFlagDictionary at: #showSharedFlaps put: aBoolean
not.
    self == Project current "Typical case"
        ifFalse:
            ["Anomalous case where this project is not the current one,
            we do not modify Preference nor hide or show the flaps on the
screen."]
        ifTrue:
            [Preferences setPreference: #showSharedFlaps toValue: aBoolean not.
            aBoolean
                ifTrue:
                    [Flaps globalFlapTabsIfAny do:
                        [:aFlapTab | Flaps removeFlapTab: aFlapTab keepInList: true]]

                ifFalse:
                    [Smalltalk isMorphic ifTrue:
                        [self currentWorld addGlobalFlaps]]].
    Project current assureNavigatorPresenceMatchesPreference

----

It all seems to work as I would have guessed it should work. :)
Obviously I must have missed something right? Or?

regards, G
 
(0013641 - 147 - 159 - 159 - 159 - 159 - 159)
laza
04-08-10 10:13

I can't reproduce this in a pre 4.1 trunk image.
There seems to be an newer version of the proposed method in the image.
Can we close this issue?
 
(0013697 - 23 - 26 - 26 - 26 - 26 - 26)
laza
04-13-10 12:29

No feedback -> resolved
 

- Issue History
Date Modified Username Field Change
07-08-05 00:33 masm New Issue
07-08-05 00:35 masm Note Added: 0001717
07-08-05 00:37 KenCausey Reporter masm => gokr
07-08-05 00:37 KenCausey Assigned To KenCausey =>
07-08-05 00:37 KenCausey Status assigned => new
07-08-05 00:37 KenCausey Category Any => MVC
07-08-05 00:37 KenCausey Description Updated
10-13-08 02:23 wiz Relationship added child of 0007212
04-08-10 10:13 laza Note Added: 0013641
04-08-10 10:13 laza Status new => feedback
04-13-10 12:29 laza Status feedback => resolved
04-13-10 12:29 laza Fixed in Version  => trunk
04-13-10 12:29 laza Resolution open => unable to reproduce
04-13-10 12:29 laza Assigned To  => laza
04-13-10 12:29 laza Note Added: 0013697
04-18-10 21:51 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
61 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker