Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001441 [Squeak Packages] BFAV minor always 07-08-05 21:52 07-17-06 20:23
Reporter ned View Status public  
Assigned To gokr
Priority normal Resolution won't fix  
Status closed  
Summary 0001441: [BUG] BFAV multiple To: headers
Description On Monday 28 June 2004 9:27 pm, I wrote:
> > I don't know if this is actually the problem, and whether it's the
> > fault of BFAV or the Squeak email sender.
>
> I don't know, though RFC-822 appears to explicitly allow it

And apparently this was fixed in RFC-2822,
which says that the maximum number of each kind of various fields is 1:

   The following table indicates limits on the number of times each
   field may occur in a message header as well as any special
   limitations on the use of those fields. An asterisk next to a value
   in the minimum or maximum column indicates that a special restriction
   appears in the Notes column.

Field Min number Max number Notes

from 1 1 See sender and 3.6.2
sender 0* 1 MUST occur with multi-address from - see 3.6.2
reply-to 0 1
to 0 1
cc 0 1
bcc 0 1
message-id 0* 1 SHOULD be present - see 3.6.4
in-reply-to 0* 1 SHOULD occur in some replies - see 3.6.4
references 0* 1 SHOULD occur in some replies - see 3.6.4
subject 0 1
Additional Information
Attached Files

- Relationships
related to 0000151assigned gokr Squeak MailMessage cannot send to more than one email address 

- Notes
(0001724 - 376 - 482 - 529 - 529 - 529 - 529)
KenCausey
07-08-05 21:53

"Frank Shearar" <frank.shearar@rnid.org.uk>:

"Which means that MailMessage should ensure there's only one To header (and
so on), surely? So if you wanted to send a MailMessage to foo, bar and baz,
I'd imagine we'd want to do something like

  mailmsg addRecipient: 'foo'; addRecipient: 'bar'; addRecipient: 'baz'

or

  mailmsg addRecipients: #('foo' 'bar' 'baz')."
 
(0001725 - 100 - 128 - 168 - 168 - 168 - 168)
KenCausey
07-08-05 21:54

Ned Konz <ned@bike-nomad.com>:

"I think that's right. And it should result in a single To: line."
 
(0001726 - 116 - 154 - 201 - 201 - 201 - 201)
KenCausey
07-08-05 21:54

"Frank Shearar" <frank.shearar@rnid.org.uk>:

"Cool. I'll whip something up quickly and submit it as a ChangeSet."
 
(0003229 - 101 - 101 - 225 - 225 - 225 - 225)
FrankShearar
12-08-05 16:07

This thread relates to http://bugs.impara.de/view.php?id=151 [^] where we discuss a changeset I proposed.
 
(0003233 - 234 - 246 - 246 - 246 - 246 - 246)
KenCausey
12-08-05 20:21

Frank,

That's what the Relatiships feature is for. Do you not see a drop down box, text field, and 'Add' button for a 'New relationship'? I ask because it wouldn't be the first time a feature is available to me and not to others.
 
(0003238 - 120 - 142 - 142 - 142 - 142 - 142)
FrankShearar
12-09-05 05:18

Hi Ken,

No, I don't see a "new relationship" dropdown. That's probably because I'm a reporter on Mantis/this project?
 
(0003243 - 147 - 171 - 171 - 171 - 171 - 171)
KenCausey
12-09-05 16:56

Frank,

Right you are, I should have checked that. ....

There, you are now a Developer. Could you confirm that you now have that capability?
 
(0003251 - 79 - 79 - 79 - 79 - 79 - 79)
FrankShearar
12-09-05 22:08

Thanks Ken, I now see the relationship dropdown along with several new buttons.
 
(0005966 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
07-17-06 20:23

BFAV is retired
 

- Issue History
Date Modified Username Field Change
07-08-05 21:52 KenCausey New Issue
07-08-05 21:53 KenCausey Reporter KenCausey => ned
07-08-05 21:53 KenCausey Note Added: 0001724
07-08-05 21:54 KenCausey Note Added: 0001725
07-08-05 21:54 KenCausey Note Added: 0001726
12-08-05 16:07 FrankShearar Note Added: 0003229
12-08-05 20:20 KenCausey Relationship added related to 0000151
12-08-05 20:21 KenCausey Note Added: 0003233
12-09-05 05:18 FrankShearar Note Added: 0003238
12-09-05 16:56 KenCausey Note Added: 0003243
12-09-05 22:08 FrankShearar Note Added: 0003251
12-10-05 21:14 gokr Status new => assigned
12-10-05 21:14 gokr Assigned To  => gokr
07-17-06 20:23 MarcusDenker Status assigned => closed
07-17-06 20:23 MarcusDenker Note Added: 0005966
07-17-06 20:23 MarcusDenker Resolution open => won't fix


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
77 total queries executed.
52 unique queries executed.
Powered by Mantis Bugtracker