Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001444 [Squeak] Morphic minor always 07-08-05 22:35 03-29-06 23:45
Reporter KenCausey View Status public  
Assigned To
Priority normal Resolution duplicate  
Status closed   Product Version 3.8
Summary 0001444: [BUG] TransformatinMorph and translucent colors
Description =?iso-8859-1?Q?Nathanael_Sch=E4rli?= <n.schaerli@gmx.net>:

"Working on a Genie demo I have just realized that the
TransformationMorph does not seem to work properly with translucent
colors. As an example, do the following:

- Create a EllipseMorph and open it
- Change the color of the ellipse to a translucent color (e.g., "self
color: (Color red alpha: 0.5)")
- Open the halos on the EllipseMorph and rotate it.

You will see that the translucency goes away and the EllipseMorph
suddenly appears in a weird color. Also if you change the color of the
Ellipse again (e.g., to another translucent color), this does not work
properly.

Is this problem known? If not, can someone try to fix it? (I'm extremely
short on time right now and so it would be great if I didn't have to
dive into this myself).

PS: I'm pretty sure that this problem is caused by the
TransformationMorph the Ellipse is embedded into when rotated."
Additional Information
Attached Files

- Relationships
has duplicate 0002241feedback  Translucent color lost when rotating a morph 

- Notes
(0001727 - 68 - 90 - 90 - 90 - 90 - 90)
KenCausey
07-08-05 22:35

karl.ramberg@chello.se:

"FormCanvas does not handle translucency"
 

- Issue History
Date Modified Username Field Change
07-08-05 22:35 KenCausey New Issue
07-08-05 22:35 KenCausey Note Added: 0001727
11-19-05 23:54 KenCausey Relationship added has duplicate 0002241
03-29-06 23:45 MarcusDenker Status new => closed
03-29-06 23:45 MarcusDenker Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
39 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker