Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001445 [Squeak] Files minor always 07-08-05 22:40 07-22-13 02:25
Reporter KenCausey View Status public  
Assigned To cdegroot
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0001445: [BUG] isAbsolute: not understood by UnixFileDirectory
Description black@cse.ogi.edu:

"While browsing a directory on MacOSX with the file list tool, I got a
walkback as FileList attempted to gte the brief contents of a file.

isAbsolute: is defined on MacFileDirectory, but in this walkback itios
being sent to the class variable DirectoryClass, defined in
FileDirectory, and whose value is UnixFileDirectory. I'm not sure why
this is so (since differernt subclasses of FileDirectory should
presumably have different DirectoryClass'es). Maybe it should be a
class instance variable? Or maybe MacFileDirectory>>#fullNameFor: , the
only method outside of the FileDirectory class to access this variable,
should not be doing so?"
Additional Information
Attached Files

- Relationships
related to 0001848new  FileList ought to flush in some manner when an image starts up on a different machine 

- Notes
(0001728 - 526 - 644 - 684 - 684 - 684 - 684)
KenCausey
07-08-05 22:41

Ned Konz <ned@bike-nomad.com>:

"Actually, I believe that the problem is that there's a lot of code that
assumes that there is a single directory class that can be asked for things
like:

* filename separator
* absoluteness
* root directories

etc.

And of course it's being used to answer queries having to do with arbitrary
path names.

But I think that since there is assumed to be a global namespace for files,
then we should make sure that the file directory classes can all respond to
isAbsolute:."
 
(0002905 - 288 - 312 - 312 - 312 - 312 - 312)
cdegroot
10-19-05 22:18

As far as I can tell, in 3.9a #isAbsolute: is only used within the MacFileDirectory stuff. Which looks ok with me.

So the actual issue is probably why the file directory instance is of MacFileDirectory while DirectoryClass == UnixFileDirectory...

Needs someone on a Mac to look at.
 
(0002927 - 219 - 219 - 219 - 219 - 219 - 219)
frankcag
10-20-05 05:26

I don't see this error on OSX 10.4.2. However this image was never used on other then OSX so it could be as Tim says, this is really mantis bug 1848, FileList is not flushing when the image is started on a different OS.
 
(0003303 - 116 - 116 - 116 - 116 - 116 - 116)
cdegroot
12-12-05 23:34

This is probably related to 1848--we need to clean FileLists, FileDirectory instances, and whatnot at image startup.
 
(0003304 - 78 - 78 - 78 - 78 - 78 - 78)
cdegroot
12-12-05 23:34

acknowledged that this code path is possible, should be solved as part of 1848
 
(0014406 - 24 - 24 - 24 - 24 - 24 - 24)
tim
07-22-13 02:25

Seemingly fixed long ago
 

- Issue History
Date Modified Username Field Change
07-08-05 22:40 KenCausey New Issue
07-08-05 22:41 KenCausey Note Added: 0001728
10-19-05 21:55 cdegroot Status new => assigned
10-19-05 21:55 cdegroot Assigned To  => cdegroot
10-19-05 22:18 cdegroot Note Added: 0002905
10-19-05 22:23 cdegroot Category System => Files
10-20-05 00:37 tim Relationship added related to 0001848
10-20-05 05:26 frankcag Note Added: 0002927
12-12-05 23:34 cdegroot Note Added: 0003303
12-12-05 23:34 cdegroot Note Added: 0003304
12-12-05 23:34 cdegroot Status assigned => acknowledged
12-15-05 11:09 pmm Issue Monitored: pmm
07-22-13 02:25 tim Status acknowledged => closed
07-22-13 02:25 tim Note Added: 0014406
07-22-13 02:25 tim Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
46 unique queries executed.
Powered by Mantis Bugtracker