Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001484 [Squeak] Morphic minor always 07-17-05 03:55 02-15-06 19:04
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0001484: [Bug] Halos persist after object is dropped into trash with grab halo. (Which grabs its morph back out)
Description This one is fun.

Get an object.
Call up halos for it.
Use the grab handle to move it over to the trash.
The trash makes its "got it" sound.
The object disappears and immediately reappears.

Now drop the grab handle so the object is over the trash and its halos are still pressent.

Now mousing on the object itself will put it in the trash and the halos will jump to mid-screen. If you pick up the grab handle the object will reappear.

Alternately if you pickup the brown move handle you will not see the object
but the brown handle will be constrained by a rectangle the exact size of the trash's scrapbook.
Additional Information When the trash is retaining lost objects the deleted object regains an owner and a world. The halos are still focused on the object and adapt.

This is what makes trying to delete an object which you have "grabbed" so frustrating.

So fixing it becomes a question of whose responsibility is it to release the halos focus?
 
The trashMorph, the haloMorph?, or the morph itself when it responds to delete?

If you know the elegant answer to this riddle please jump in.
Attached Files  TrashCanFixA-wiz.2.cs [^] (1,467 bytes) 08-04-05 05:57

- Relationships

- Notes
(0002129 - 1057 - 1153 - 1153 - 1153 - 1153 - 1153)
wiz
08-04-05 05:55

This turns out to be several problems.
And I think I have misinterpreted what grab morph is doing.

The misinterpretation stems from the fact that entering the TrashCanMorph sets the hand to visible: false.
The visible bool was meant to inform the hand whether it needed to draw itself or not.
No display was needed when the hdwe cursor is displaying itself. If the hand is dragging things around it needs to draw itself and its submorphsand visible is meant to be true.

But here it is being used (poorly) as a hack to disappear the hands contents.

The second bug is that the halo for the deleted object was not being removed when it was stashed into scraps.

I've uploaded the fixes for the first two bugs.
Cursor and object remain visible until object is put in trash.
The halos now get removed at the appropriate moment.


Even having fixed those to bugs, a third bug remains. Using the grab handle to move the object over the trash can changes the state of the trash twice leaving it mostly off. Why this is I still haven't found out.
 
(0003872 - 698 - 800 - 800 - 800 - 800 - 800)
MarcusDenker
02-15-06 19:04

in 3.9a

Name: MorphicExtras-jmv.9
Author: jmv
Time: 12 January 2006, 1:33:41 pm
UUID: 2720167c-765e-9541-8f14-dd3789d8fca8
Ancestors: MorphicExtras-CdG.7

This version includes stuff from one or more of:
Mantis-1092-MorphDropFix, fix by Edgar De Cleene (edc) and Scott Wallace (sw)
Mantis-0503-TargetSighting, fix by Jerome Peace (wiz)
Mantis-1015-SnapView, fix by Jerome Peace (wiz)
Mantis-1771-ClickExerciser, fix by Jerome Peace (wiz)
Mantis-1625-Thumbnails, fix by Jerome Peace (wiz)
Mantis-1484-TrashHalo, fix by Jerome Peace (wiz)
Mantis-1454-ArrowPrototypeFix, fix by Jerome Peace (wiz)
Mantis-1347-ListDoubleClick, fix by Jerome Peace (wiz)
Reviewed by Juan Vuletich (jmv)
 

- Issue History
Date Modified Username Field Change
07-17-05 03:55 wiz New Issue
08-04-05 05:55 wiz Note Added: 0002129
08-04-05 05:57 wiz File Added: TrashCanFixA-wiz.2.cs
02-15-06 19:04 MarcusDenker Status new => closed
02-15-06 19:04 MarcusDenker Note Added: 0003872
02-15-06 19:04 MarcusDenker Resolution open => fixed
02-15-06 19:04 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
41 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker