Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001590 [Squeak] Kernel minor always 08-01-05 14:20 03-01-06 19:03
Reporter MarcusDenker View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0001590: dupAllCtrlAltKeysPref-dew
Description from old 3.9:

Change Set: dupAllCtrlAltKeysPref-dew
Date: 13 December 2004
Author: Doug Way

Adds a new preference duplicateAllCtrlAndAltkeys to duplicate all Ctrl and Alt modifier key commands, which causes all Ctrl key commands to behave the same as Alt-key commands. The original Ctrl (a.k.a. 'shift') key commands are still available via Ctrl-Shift and Alt-Shift.

This differs from the existing ctrlAlt prefs which only duplicate/swap the eight editing keys. Also includes code to prevent these other two conflicting prefs from being activated at the same time.

The three related prefs (swapCtrlAndAltKeys, duplicateCtrlAndAltKeys, duplicateAllCtrlAndAltKeys) should really be made into a radio button preferences set sometime in the future (like the Halo look preferences), since only one can be turned on at a time. This would eliminate the need for the #changed methods.

See 'modifier' discussion on squeak-dev from 12/3/2004 for more details on why this was provided.
Additional Information
Attached Files  6535dupAllCtrlAltKeys-dew.cs [^] (6,079 bytes) 08-01-05 14:20

- Relationships

- Notes
(0004232 - 8 - 8 - 8 - 8 - 8 - 8)
MarcusDenker
03-01-06 01:03

for 7005
 
(0004266 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
03-01-06 19:03

7005
 

- Issue History
Date Modified Username Field Change
08-01-05 14:20 MarcusDenker New Issue
08-01-05 14:20 MarcusDenker File Added: 6535dupAllCtrlAltKeys-dew.cs
08-01-05 18:59 KenCausey Assigned To KenCausey =>
08-01-05 18:59 KenCausey Status assigned => new
08-01-05 18:59 KenCausey Category Any => Kernel
03-01-06 01:03 MarcusDenker Status new => resolved
03-01-06 01:03 MarcusDenker Fixed in Version  => 3.9
03-01-06 01:03 MarcusDenker Resolution open => fixed
03-01-06 01:03 MarcusDenker Assigned To  => MarcusDenker
03-01-06 01:03 MarcusDenker Note Added: 0004232
03-01-06 19:03 MarcusDenker Status resolved => closed
03-01-06 19:03 MarcusDenker Note Added: 0004266


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker