Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001613 [Squeak] Kernel minor always 08-05-05 00:09 03-01-06 19:02
Reporter lexspoon View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0001613: [ENH] truncatedChanges-ls
Description from preamble:

"Change Set: truncatedChanges-ls
Date: 4 September 2003
Author: Lex Spoon

Handle truncated changes files more gracefully. The problem actually
can happen, and has been observed at Georgia Tech, e.g. if someone
downloads a file but does not complete the download. The current
behavior is that pink debuggers pop up; this is extremely confusing for
new users when it happens in places like the Browser.

The solution in this changeset is to fall back on the decompiler. A
more thorough solution should probably trigger a systematic invalidation
of all source pointers past the end of the changes file, because as time
goes on the changes file will eventually grow large enough to cover the
lost code and the routine will start returning random method code for
the invalid source pointers."
Additional Information
Attached Files  truncatedChanges-ls.cs.gz [^] (1,333 bytes) 08-05-05 00:09
 truncatedChanges-ls.1.cs.gz [^] (1,270 bytes) 08-06-05 17:26
 truncatedChanges39-md.1.cs [^] (2,180 bytes) 02-28-06 19:02

- Relationships

- Notes
(0002144 - 44 - 66 - 66 - 66 - 66 - 66)
KenCausey
08-05-05 00:09

karl.ramberg@chello.se:

"[er] looks good"
 
(0002145 - 264 - 282 - 282 - 282 - 282 - 282)
KenCausey
08-05-05 00:11

WARNING!!!

I was able to file this into a 3.8-6665-basic image without errors. However this changeset includes a SLIP redefining FileStream class>>concreteStream undoing a Multilingualization related change. I don't think this method was meant to be included.
 
(0002155 - 119 - 131 - 131 - 131 - 131 - 131)
lexspoon
08-05-05 15:44
edited on: 08-05-05 15:54

Yes, that concreteStream method should never end up in a FIX changeset. It is surely an accident that it's in there.

 
(0002156 - 74 - 74 - 74 - 74 - 74 - 74)
KenCausey
08-05-05 17:41

So is this still relevant enough for you to provide a corrected changeset?
 
(0002183 - 598 - 634 - 634 - 634 - 634 - 634)
lexspoon
08-06-05 17:32

New version updated that does not include the method.

I have not tested this in current Squeak's, but it is just a few lines of code and it looks like it will still have its intended effect in newer Squeak.

I do think this is still worth considering of inclusion. Without this change, a truncated changes file can cause the system browser to pop up pink pre-debug windows.

Better fixes are possible. It would be best to check the changes file at startup and then, if there is a problem, repair the image to be consistent. At least, though, this change set cures the most common symptom.
 
(0004263 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
03-01-06 19:02

7005
 

- Issue History
Date Modified Username Field Change
08-05-05 00:09 KenCausey New Issue
08-05-05 00:09 KenCausey File Added: truncatedChanges-ls.cs.gz
08-05-05 00:09 KenCausey Note Added: 0002144
08-05-05 00:11 KenCausey Note Added: 0002145
08-05-05 00:16 KenCausey Reporter KenCausey => lexspoon
08-05-05 15:44 lexspoon Note Added: 0002155
08-05-05 15:54 lexspoon Note Edited: 0002155
08-05-05 17:41 KenCausey Note Added: 0002156
08-06-05 17:26 lexspoon File Added: truncatedChanges-ls.1.cs.gz
08-06-05 17:32 lexspoon Note Added: 0002183
02-28-06 19:02 MarcusDenker File Added: truncatedChanges39-md.1.cs
02-28-06 19:02 MarcusDenker Status new => resolved
02-28-06 19:02 MarcusDenker Resolution open => fixed
02-28-06 19:02 MarcusDenker Assigned To  => MarcusDenker
03-01-06 19:02 MarcusDenker Status resolved => closed
03-01-06 19:02 MarcusDenker Note Added: 0004263
03-01-06 19:02 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker