Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001684 [Croquet] Any minor always 08-16-05 02:38 08-20-05 03:27
Reporter elenzil View Status public  
Assigned To
Priority normal Resolution no change required  
Status resolved  
Summary 0001684: GLByte color components are in range 0-127, not 0-255
Description When drawing points (and presumably other GL primitives)
with glDrawArrays (and presumably other methods)
with color components of type GLByte,
the color space seems to be the range 0-127, not 0-255.

Values of 127 are full, values of 128 and above are transformed to zero.

So when you would expect grey from 127, 127, 127, you get white,
and when you would expect the same grey but with a tiny bit of yellow added from 128, 128, 127, you get solid blue.

See screenshot below and attached TPrimitive subclass which demonstrate.

http://www.citris-uc.org/hosted/projects/ith/screenshots/GLByte%20colors.png [^]
Additional Information
Attached Files  TByteArrayPoint.st [^] (1,650 bytes) 08-16-05 02:38

- Relationships

- Notes
(0002448 - 140 - 140 - 140 - 140 - 140 - 140)
bert
08-20-05 03:26

The range of GLByte is -128 to 127. This is not a bug. Read the OpenGL Spec. You'll also find GLUnsignedByte there with a range of 0 to 255.
 

- Issue History
Date Modified Username Field Change
08-16-05 02:38 elenzil New Issue
08-16-05 02:38 elenzil File Added: TByteArrayPoint.st
08-20-05 03:26 bert Status new => resolved
08-20-05 03:26 bert Resolution open => no change required
08-20-05 03:26 bert Assigned To  => bert
08-20-05 03:26 bert Note Added: 0002448
08-20-05 03:27 bert Assigned To bert =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
38 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker