Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001723 [Squeak] Morphic minor always 08-20-05 04:39 08-27-05 18:09
Reporter mzimmerm View Status public  
Assigned To
Priority normal Resolution open  
Status closed   Product Version
Summary 0001723: [BUG][FIX] Changing the name of a SystemWindow
Description frankcag@crystal-objects.com:


"Change Set: SystemWindowLabel-fc
Date: 15 December 2004
Author: Frank Caggiano

If the label of a system window was changed by either shift-clicking in
the label OR clicking on the halo label the underlying project wasn't
renamed; the system window wasn't informed of the change."
Additional Information
Attached Files  SystemWindowLabel-fc.cs.gz [^] (2,331 bytes) 08-20-05 04:39

- Relationships
duplicate of 0000622closed frankcag Renaming a project with shift+click on SystemWindow title 

- Notes
(0002452 - 155 - 207 - 246 - 246 - 246 - 246)
mzimmerm
08-20-05 04:48

Lex Spoon <lex@cc.gatech.edu>:

"( [et] seems to work )

I don't understand this code in general, but it does seem to fix the bug
it says it fixes.
"
 
(0002453 - 281 - 287 - 287 - 287 - 287 - 287)
mzimmerm
08-20-05 05:00

When moving this item from BFAV to Mantis, I verified the attached changeset installs in 3.8-6665. However, I am not sure I understand where this fix is needed, in 3.8-6665, if I do (on a project window): Halo==>Menu==>Edit Label, the project's name changes, even without this fix.
 
(0002546 - 10 - 10 - 10 - 10 - 10 - 10)
MarcusDenker
08-27-05 18:08

duplicated
 

- Issue History
Date Modified Username Field Change
08-20-05 04:39 mzimmerm New Issue
08-20-05 04:39 mzimmerm File Added: SystemWindowLabel-fc.cs.gz
08-20-05 04:48 mzimmerm Note Added: 0002452
08-20-05 05:00 mzimmerm Note Added: 0002453
08-27-05 18:07 MarcusDenker Relationship added duplicate of 0000622
08-27-05 18:08 MarcusDenker Status new => closed
08-27-05 18:08 MarcusDenker Note Added: 0002546


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker