Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001734 [Squeak] Kernel minor always 08-22-05 05:56 02-14-06 10:39
Reporter mzimmerm View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0001734: [ENH] remove deprecated Chronology methods in 3.9 [cd][su][sm]
Description Brent Pinkney <brent.pinkney@aircom.co.za>:

"
Hi,

'From Squeak3.9alpha of ''2 November 2004'' [latest update: 0006537] on 30
January 2005 at 9:50:13 am'!
"Change Set: removeDeprecatedChronology-brp
Date: 30 January 2005
Author: Brent Pinkney

Remove all deprected methods from Kernel-Chronology.

The methods were deprecated and 3.7 and are therefore due for removal in
3.9.

All 406 tests in Kernel-Chronology Tests succeed and the PDAMorph still
works.

Any empty categories (deprecated) are removed by the postscript.

Brent
"
Additional Information
Attached Files  removeDeprecatedChronology-brp.1.cs.gz [^] (6,657 bytes) 08-22-05 05:56
 removeDeprecatedChronology-brp.2.cs.gz [^] (6,943 bytes) 08-22-05 06:04

- Relationships

- Notes
(0002489 - 570 - 687 - 687 - 757 - 757 - 757)
mzimmerm
08-22-05 05:59

tomkoenig@mindspring.com:

"
 ( [er][et][su][cd] Recommend including )

Tested and inspected in 3.9a 0006550. Obsoletes 30 methods and updates 14.
And as Brent says it leaves all 406 Chronology sunit tests passing. So
I recommend approving this change. I do suspect there is one bug:
Timespan>>firstDate appears to still be used by
WeekMorph>>selectedDates. If for example, you do the following:
WeekMorph new openInWorld; inspect
and then click on one of the days in the WeekMorph and in the Inspector
do
self selectedDates
you will get an exception
"
 
(0002490 - 503 - 627 - 675 - 675 - 675 - 675)
mzimmerm
08-22-05 06:01

Brent Pinkney <brent.pinkney@aircom.co.za>:

"Hi,

Attached is the second version, after Tom's review.

This version fixed the WeekMorph>>selectedDates to not use and removed
methods.

It also deletes the unwanted, unused classes RuleDate, RuleIndexDate and
RuleSelectionCodeDate which were erronously introduced by inclusion of
ANSI compatible collections.

All these methods and code have been marked for deprectation since 3.7
using the official #deprecated methods.

Brent
"
 
(0002491 - 256 - 256 - 256 - 256 - 256 - 256)
mzimmerm
08-22-05 06:06

When moving this item from BFAV to Mantis, I verified the second attachement removeDeprecatedChronology-brp.2.cs.gz (which from the discussion is corrected version of the first), installs correctly into 3.8-6665 final, but no further testing was performed.
 
(0002696 - 109 - 133 - 133 - 133 - 133 - 133)
ducasse
09-17-05 22:00

Hi brent

now the deprecated method goes into a package. So could you package them in 38Deprecated?

Stef
 
(0002697 - 212 - 218 - 218 - 218 - 218 - 218)
MarcusDenker
09-17-05 22:07

We moved all deprecated method into it's own mc package... so this changeset needs to be analysed
if it contains other useful code (e.g. changes to the tests, or the fixes for the PDAMorph (now on SqueakSource).
 
(0003829 - 6 - 6 - 6 - 6 - 6 - 6)
MarcusDenker
02-14-06 10:39

in 3.9
 

- Issue History
Date Modified Username Field Change
08-22-05 05:56 mzimmerm New Issue
08-22-05 05:56 mzimmerm File Added: removeDeprecatedChronology-brp.1.cs.gz
08-22-05 05:59 mzimmerm Note Added: 0002489
08-22-05 06:01 mzimmerm Note Added: 0002490
08-22-05 06:04 mzimmerm File Added: removeDeprecatedChronology-brp.2.cs.gz
08-22-05 06:06 mzimmerm Note Added: 0002491
09-17-05 22:00 ducasse Note Added: 0002696
09-17-05 22:07 MarcusDenker Note Added: 0002697
02-14-06 10:39 MarcusDenker Status new => closed
02-14-06 10:39 MarcusDenker Note Added: 0003829
02-14-06 10:39 MarcusDenker Resolution open => fixed
02-14-06 10:39 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
62 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker