Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001802 [Squeak] Kernel text always 09-16-05 10:46 10-01-05 22:04
Reporter laza View Status public  
Assigned To
Priority low Resolution fixed  
Status closed   Product Version 3.9
Summary 0001802: Add a warning hint to Delay comment
Description I think adding andreas comment from 0001644 to the Delay comment is a good idea:

"A word of advice:
This is THE highest priority code which is run in Squeak, in other words it is time-critical. The speed of this code is critical for accurate responses, it is critical for network services, it affects every last part of the system.

In short: Don't fix it if it ain't broken! This code isn't supposed to be beautiful, it's supposed to be fast! The reason for duplicating code is to make it fast. The reason for not using ifNil:[]ifNotNil:[] is that the compiler may not inline those. Since the effect of changes are VERY hard to predict it is best to leave things as they are for now unless there is an actual need to change anything."
Additional Information
Attached Files

- Relationships
related to 0001644closed  [ENH] DelayRefactoring-st 

- Notes
(0002681 - 108 - 108 - 108 - 108 - 108 - 108)
laza
09-16-05 10:55

Reminder sent to: andreas

Since you're the author of that text you might want to grant permission for its use or to tweak it a bit. :)
 
(0002684 - 112 - 112 - 112 - 188 - 188 - 188)
laza
09-16-05 12:39

Apperently there will be such a hint in the Delay comment with the next updates. See comment in 0001644 by Marcus.
 
(0002753 - 30 - 30 - 30 - 30 - 30 - 30)
ducasse
10-01-05 22:03

comment added in 3.9a script 4
 

- Issue History
Date Modified Username Field Change
09-16-05 10:46 laza New Issue
09-16-05 10:48 laza Relationship added related to 0001644
09-16-05 10:50 laza Description Updated
09-16-05 10:52 laza Description Updated
09-16-05 10:55 laza Issue Monitored: andreas
09-16-05 10:55 laza Note Added: 0002681
09-16-05 12:39 laza Status new => resolved
09-16-05 12:39 laza Fixed in Version  => 3.9
09-16-05 12:39 laza Resolution open => fixed
09-16-05 12:39 laza Assigned To  => laza
09-16-05 12:39 laza Note Added: 0002684
09-16-05 12:39 laza Assigned To laza =>
10-01-05 22:03 ducasse Status resolved => closed
10-01-05 22:03 ducasse Note Added: 0002753


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
58 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker