Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001879 [Squeak] Morphic minor always 10-06-05 21:01 10-14-05 21:38
Reporter Ron View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0001879: Chess Morph Error Causes VM Crash
Description Open Chess Morph, click on white piece causes endless loop and vm crash.

Problem was>
String
    findFirstInString: myPieces asString
    inSet: EmptyPieceMap
    startingAt: square + 1.

Where myPieces was returning a byte array. I added asString and it appears to work now.
Additional Information
Attached Files  ChessMoveGenerator.RJT.1.cs.gz [^] (842 bytes) 10-06-05 21:01

- Relationships
related to 0001591resolved  Squeak 5.2 Chess game crashes squeak 

- Notes
(0002808 - 41 - 41 - 41 - 119 - 119 - 119)
andreas
10-08-05 12:28

The fix is incorrect. Please see 0001591
 
(0002811 - 85 - 85 - 85 - 85 - 85 - 85)
Ron
10-09-05 05:06

Sorry about that I should have done a more through search. (Still cutting my teeth).
 
(0002836 - 75 - 75 - 75 - 75 - 75 - 75)
KenCausey
10-12-05 20:58

I think this means that this fix should be harvested for the Games package.
 
(0002837 - 559 - 559 - 559 - 559 - 559 - 559)
andreas
10-13-05 10:57

Yes, please use the fix from Squeakland. The fix which is referenced above is actually the worst one of all of them (sorry to say that Ron ;-) since it not only uses the non-primitive version (bad for speed) but also adds to the allocation overhead by converting the byte array to a string. And unless I'm mistaken this alone will slow down the chess game by a factor of two (because this code is soooo heavily used in the game). I have actually sped up the whole game by a factor of four (no kidding!) by carefully avoiding allocations in the move generator.
 
(0002863 - 61 - 61 - 61 - 61 - 61 - 61)
asm
10-14-05 21:24

Andreas's fix from 1591 is included now in the Games Package.
 
(0002864 - 39 - 39 - 39 - 39 - 39 - 39)
KenCausey
10-14-05 21:38

Fix incorporated by package maintainer.
 

- Issue History
Date Modified Username Field Change
10-06-05 21:01 Ron New Issue
10-06-05 21:01 Ron File Added: ChessMoveGenerator.RJT.1.cs.gz
10-08-05 12:27 andreas Relationship added related to 0000159
10-08-05 12:27 andreas Relationship deleted related to 0000159
10-08-05 12:28 andreas Relationship added related to 0001591
10-08-05 12:28 andreas Note Added: 0002808
10-09-05 05:06 Ron Note Added: 0002811
10-12-05 20:58 KenCausey Note Added: 0002836
10-13-05 10:57 andreas Note Added: 0002837
10-14-05 21:24 asm Note Added: 0002863
10-14-05 21:38 KenCausey Status new => closed
10-14-05 21:38 KenCausey Note Added: 0002864
10-14-05 21:38 KenCausey Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
44 unique queries executed.
Powered by Mantis Bugtracker