Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002116 [Squeak] Morphic minor always 10-24-05 07:33 04-01-06 20:42
Reporter wiz View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version 3.8
Summary 0002116: Halo rotation of a true type font throws up a debug window.
Description For this one.

Get a true type font from the objects morph.
Put the halos around it and use the blue rotation handle to rotate it.

The first time you try it you get a debuger window because Morph>transferStateToRenderer: sends
aRenderer(a MatrixTransformMorph) simplySetVisible:
which MTM does not understand. You will also get a series of debugger windows complianing that UndefinedObject DNU degrees.

The second time you try it the type will rotate (the reference point is the top left of the screen).

If you use the yellow growth handle to squash the font and then rotate it you will get Italic lettering with the rotation.


Additional Information There are three layers of bugs.

MTM never learned simplySetVisible (which looks like it was added circa 2004)

MTM confuses centerOfRotation with its reference point I think the top left reference point is at 0.5@0.5 the default center of rotation for morph.

Halos have a protocol designed to work with Transformation morphs and polygons. MTM does not take this protocol into account (in particular it denies that it is a flex morph) one of the results is several layers of MTMs can be inserted and are when both the growth and rotation handle are used.

The effect is sort of interesting but not easily controlable.


This is an easily reproducible example. See also Mantis#857 for other MTM bug documentation. Because MTM is essential for full use of TTFonts it is obviously worth fixing and bringing up to date.


See also 0000851,0000877
Attached Files  FlexFixes-wiz.1.cs [^] (3,420 bytes) 11-06-05 23:46

- Relationships
child of 0005560new  MatrixTransformationMorph needs examining and fixing. 

- Notes
(0002961 - 50 - 50 - 50 - 50 - 50 - 50)
andreas
10-25-05 05:29

This is not a graphics but rather a Morphic issue.
 
(0003036 - 735 - 813 - 813 - 813 - 813 - 813)
wiz
11-06-05 23:52

[FIX] Uploaded FlexFixes-wiz.1.cs which addresses the problem.

The fix is two fold.

First a backstop for TransformationMorph >>setSimplyVisible: is defined in Morph since the message can be sent to renderers that do not inherit from TFmorph.

Secondly MatrixTransformMorph>>asFlexOf: is changed to initialze rotation degrees (so nil isn't left having to understand words it doesn't know).


I also used the opportunity to initialize the center of rotation to the middle of the flexed morph. This might not solve all the problems with rotation center but its a nice start.

The halo issue remains (rotation and scaling at the same time cause two levels of rendering which will cause the italic look among other symptoms).
 
(0004619 - 11 - 11 - 11 - 11 - 11 - 11)
MarcusDenker
03-29-06 23:37

to be added
 
(0004649 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
04-01-06 20:42

7022
 

- Issue History
Date Modified Username Field Change
10-24-05 07:33 wiz New Issue
10-25-05 05:29 andreas Note Added: 0002961
10-25-05 05:29 andreas Category Graphics => Morphic
11-06-05 23:46 wiz File Added: FlexFixes-wiz.1.cs
11-06-05 23:52 wiz Note Added: 0003036
03-17-06 20:12 cdan Issue Monitored: cdan
03-29-06 23:37 MarcusDenker Status new => resolved
03-29-06 23:37 MarcusDenker Fixed in Version  => 3.9
03-29-06 23:37 MarcusDenker Resolution open => fixed
03-29-06 23:37 MarcusDenker Assigned To  => MarcusDenker
03-29-06 23:37 MarcusDenker Note Added: 0004619
04-01-06 20:42 MarcusDenker Status resolved => closed
04-01-06 20:42 MarcusDenker Note Added: 0004649
07-05-07 00:52 wiz Relationship added child of 0005560


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
64 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker