Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002124 [Squeak] Morphic major always 10-25-05 14:46 01-21-06 22:09
Reporter Eddie Cottongim View Status public  
Assigned To dgd
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002124: 6695: Right click on world gives DNU
Description Did an update on 6693 to 6695 like Stephen asked for.

Right click on world gives: ProjectDNU #supressFlapsString

Filed as major because this breaks the usual way I do updates (there is probably some other way, but I don't know offhand).
Additional Information
Attached Files  Project.kfr.1.cs [^] (444 bytes) 10-31-05 10:24
 flapFix.1.cs [^] (690 bytes) 11-04-05 23:18

- Relationships
related to 0002165closed KenCausey World menu - flaps 

- Notes
(0003006 - 881 - 1127 - 1127 - 1127 - 1127 - 1127)
Eddie Cottongim
10-28-05 22:40

Stack dump: (I cannot find any place where suppressFlapsString was implemented)

Project(Object)>>doesNotUnderstand: #suppressFlapsString
UpdatingMenuItemMorph>>updateContents
[] in MenuMorph>>popUpAt:forHand:in:allowKeyboard: {[:m | m updateContents]}
Array(SequenceableCollection)>>do:
MenuMorph>>popUpAt:forHand:in:allowKeyboard:
MenuMorph>>popUpAt:forHand:in:
MenuMorph>>popUpEvent:in:
PasteUpMorph>>yellowButtonClickOnDesktopWithEvent:
PasteUpMorph>>putUpWorldMenu:
PasteUpMorph>>invokeWorldMenu:
PasteUpMorph>>mouseDown:
PasteUpMorph(Morph)>>handleMouseDown:
MouseButtonEvent>>sentTo:
PasteUpMorph(Morph)>>handleEvent:
MorphicEventDispatcher>>dispatchMouseDown:with:
MorphicEventDispatcher>>dispatchEvent:with:
PasteUpMorph(Morph)>>processEvent:using:
PasteUpMorph>>processEvent:using:
PasteUpMorph(Morph)>>processEvent:
HandMorph>>sendEvent:focus:clear:
 
(0003007 - 73 - 73 - 73 - 73 - 73 - 73)
Eddie Cottongim
10-28-05 22:55

Oops, It is implemented in CurrentProjectRefactoring which is deprecated.
 
(0003016 - 68 - 80 - 80 - 80 - 80 - 80)
KarlRamberg
10-31-05 10:24
edited on: 10-31-05 10:26

This is a simple fix. Look at the attached files: Project.kfr.1.cs

 
(0003017 - 1163 - 1409 - 1409 - 1409 - 1409 - 1409)
Eddie Cottongim
11-01-05 08:16

Thanks, I can right click now without DNU. But when I click the 'show shared tabs' options on the menu that comes up, I get..

Project(Object)>>doesNotUnderstand: #toggleFlapsSuppressed
[] in UpdatingMenuItemMorph(MenuItemMorph)>>invokeWithEvent: {[(selArgCount := selector numArgs) = 0 ifTrue: [target perform: selector] ...]}
BlockContext>>ensure:
CursorWithMask(Cursor)>>showWhile:
UpdatingMenuItemMorph(MenuItemMorph)>>invokeWithEvent:
UpdatingMenuItemMorph(MenuItemMorph)>>mouseUp:
UpdatingMenuItemMorph(MenuItemMorph)>>handleMouseUp:
MouseButtonEvent>>sentTo:
UpdatingMenuItemMorph(Morph)>>handleEvent:
MorphicEventDispatcher>>dispatchDefault:with:
MorphicEventDispatcher>>dispatchEvent:with:
UpdatingMenuItemMorph(Morph)>>processEvent:using:
MorphicEventDispatcher>>dispatchDefault:with:
MorphicEventDispatcher>>dispatchEvent:with:
MenuMorph(Morph)>>processEvent:using:
MenuMorph(Morph)>>processEvent:
MenuMorph>>handleFocusEvent:
[] in HandMorph>>sendFocusEvent:to:clear: {[ActiveHand := self. ActiveEvent := anEvent. result := focusHolder han...]}
[] in PasteUpMorph>>becomeActiveDuring: {[aBlock value]}
BlockContext>>on:do:
 
(0003019 - 47 - 47 - 173 - 173 - 173 - 173)
simon
11-01-05 19:00

See also http://bugs.impara.de/view.php?id=1653 [^]
 
(0003029 - 148 - 178 - 178 - 178 - 178 - 178)
KarlRamberg
11-04-05 23:17
edited on: 11-04-05 23:20

Ok, I moved and changed method from CurrentProjectRefactoring to Project
so it seems everything works now.
Look at attachment flapFix.1.cs
Karl

 
(0003030 - 53 - 53 - 53 - 53 - 53 - 53)
Eddie Cottongim
11-05-05 05:53

Works for me. Note to harvester: you need both files.
 
(0003031 - 24 - 24 - 24 - 24 - 24 - 24)
ducasse
11-05-05 21:08

in 3.9 - scriptLoader 44
 
(0003045 - 586 - 610 - 610 - 610 - 610 - 610)
KenCausey
11-08-05 01:09
edited on: 11-08-05 01:09

In the future, please do not close an issue and claim 'in 3.9' until this is actually true. At this date the latest update I can retrieve is 6703 which only includes ScriptLoader up to 39 and does not include this fix. Until the fix is actually in the update stream I'm willing to consider this 'resolved' but not 'closed'.

We need to maintain a seperate status between 'fix is available' and 'fix is applied' that means something like 'fix is accepted but not yet distributed' and for the moment 'resolved' seems to be the closest to this with 'closed' meaning 'fix is applied'.

 
(0003055 - 462 - 462 - 462 - 462 - 462 - 462)
KenCausey
11-09-05 19:18

Now that update 6704 has been issued and ScriptLoader is up to version 47 then I would assume that this fix has been incorporated. However I'm now noticing another possibly related problem. If I bring up the halos for the world now I can't bring up the World menu again until I give the focus to some other morph and then click back on the world. If I had the flaps suppressed and no morphs open then this could be a real problem. I suspect I would be stuck.
 
(0003592 - 13 - 13 - 13 - 13 - 13 - 13)
MarcusDenker
01-21-06 22:09

fixed in 3.9a
 

- Issue History
Date Modified Username Field Change
10-25-05 14:46 Eddie Cottongim New Issue
10-28-05 22:40 Eddie Cottongim Note Added: 0003006
10-28-05 22:55 Eddie Cottongim Note Added: 0003007
10-31-05 10:24 KarlRamberg File Added: Project.kfr.1.cs
10-31-05 10:24 KarlRamberg Note Added: 0003016
10-31-05 10:26 KarlRamberg Note Edited: 0003016
10-31-05 10:26 KarlRamberg Note Edited: 0003016
10-31-05 10:27 KarlRamberg Assigned To  => dgd
10-31-05 10:27 KarlRamberg Status new => feedback
11-01-05 08:16 Eddie Cottongim Note Added: 0003017
11-01-05 19:00 simon Note Added: 0003019
11-04-05 23:17 KarlRamberg Note Added: 0003029
11-04-05 23:18 KarlRamberg File Added: flapFix.1.cs
11-04-05 23:19 KarlRamberg Note Edited: 0003029
11-04-05 23:20 KarlRamberg Note Edited: 0003029
11-04-05 23:20 KarlRamberg Note Edited: 0003029
11-05-05 05:53 Eddie Cottongim Note Added: 0003030
11-05-05 21:08 ducasse Status feedback => closed
11-05-05 21:08 ducasse Note Added: 0003031
11-05-05 21:08 ducasse Resolution open => fixed
11-08-05 01:09 KenCausey Status closed => resolved
11-08-05 01:09 KenCausey Note Added: 0003045
11-08-05 01:09 KenCausey Note Edited: 0003045
11-09-05 19:18 KenCausey Status resolved => feedback
11-09-05 19:18 KenCausey Resolution fixed => reopened
11-09-05 19:18 KenCausey Note Added: 0003055
11-09-05 19:18 KenCausey Relationship added related to 0002165
01-21-06 22:09 MarcusDenker Status feedback => closed
01-21-06 22:09 MarcusDenker Note Added: 0003592
01-21-06 22:09 MarcusDenker Resolution reopened => fixed
01-21-06 22:09 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
114 total queries executed.
58 unique queries executed.
Powered by Mantis Bugtracker