Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002127 [Squeak] Morphic text always 10-25-05 21:53 02-24-06 21:31
Reporter kosik View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002127: Enhanced comment for the PolygonMorph
Description When I started with Squeak (some time ago), PolygonMorph puzzled me. The proposed comment is an attempt to clarify basic things.

For example, I was able to create new polygon-morph. I've got a triangle. But couldn't find a way how to add new vertices.

The "Additional Information" contains the full text of the new version of the PolygonMorph's class comment.
Additional Information This class implements a morph which can behave as four different objects depending on the the following two facts:
- is it OPEN or CLOSED?
- is it SEGMENTED or SMOOTHED.

1. The OPEN and SEGMENTED variant looks like polyline.

2. The OPEN and SMOOTHED variant looks like spline (kind of curve)

3. The CLOSED and SEGMENTED variant looks like polygon. This is actually what you get when you do
    PolygonMorph new openInWorld
You get a triangle. See below how to manipulate these objects...

4. The CLOSED and SMOOTHED variant looks like blob (???)

Prototypes of this morph can also be found in "Object Catalog". Several (different variants) of this object are among "Basic" morphs.

Explore the assiciated morph-menu. It enables you
- to toggle showing of "handles". They make it possible to
    - reposition already existing vertices (by moving yellow handles)
    - create new vertices (by moving green handles)
    - delete already existing vertices (by dragging and dropping one yellow handle closely
      nearby the adjacent yellow handle
  Handles can be made visible/hidden by shift+leftclicking the morph. This way it is possible
  to quickly show handles, adjust vertices and then again hide handles.
- making closed polygon open, i.e. converting it to a curve (and vice versa)
- toggle smoothed/segmented line/outline
- set up custom dashing (for line, curves or borders of closed polygons
- set up custom arrow-heads (for lines resp. curves)
------------------------------------------------------------------------------------------
Implementation notes:

The 1-bit fillForm to make display and containment tests reasonably fast. However, this functionality is in the process of being supplanted by balloon capabilities, which should eventually provide anti-aliasing as well.
Attached Files  PolygonMorph-enh.2.cs [^] (1,933 bytes) 10-25-05 21:53

- Relationships

- Notes
(0004064 - 7 - 7 - 7 - 7 - 7 - 7)
MarcusDenker
02-24-06 21:31

in 7003
 

- Issue History
Date Modified Username Field Change
10-25-05 21:53 kosik New Issue
10-25-05 21:53 kosik File Added: PolygonMorph-enh.2.cs
10-25-05 21:54 kosik Issue Monitored: kosik
02-24-06 21:31 MarcusDenker Status new => closed
02-24-06 21:31 MarcusDenker Note Added: 0004064
02-24-06 21:31 MarcusDenker Resolution open => fixed
02-24-06 21:31 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
39 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker