Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002148 [tweak] Any minor always 11-02-05 10:01 12-11-05 06:03
Reporter bernd View Status public  
Assigned To andreas
Priority normal Resolution fixed  
Status resolved  
Summary 0002148: CCollection: cant add Set
Description OrderedCollection new addAll: #(1 2 3) asSet; yourself <- works OK
CCollection new addAll: #(1 2 3) asSet; yourself <- fails because Sets are not indexable. Should it work?
Converting the set with asArray or asOrderedCollection resolves this problem, but I would expect the same behaviour as an OrderedCollection.
Additional Information
Attached Files

- Relationships

- Notes
(0003274 - 10 - 10 - 10 - 10 - 10 - 10)
andreas
12-11-05 06:03

Now fixed.
 

- Issue History
Date Modified Username Field Change
11-02-05 10:01 bernd New Issue
12-11-05 06:03 andreas Status new => resolved
12-11-05 06:03 andreas Resolution open => fixed
12-11-05 06:03 andreas Assigned To  => andreas
12-11-05 06:03 andreas Note Added: 0003274


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
35 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker