Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002160 [Squeak] Multilingual crash always 11-08-05 03:08 03-29-06 23:53
Reporter tim View Status public  
Assigned To ohshima
Priority high Resolution unable to reproduce  
Status closed   Product Version 3.8
Summary 0002160: File out a morph then trying to reload it fails because of a wrong file stream class
Description Create a morph - jsut a playfield should work and use menu->debug->save morph in file to save it. Now use a fileList to try to reload it. No go - see attached debug.log.

Basically it seems the ReadWriteStream>asUnZippedStream method needs to do something sensible when the input stream is not gzipped. Right now it returns a MultiByteBinaryOrTextStream when gzipped but leaves the input stream if not. Since MultiByteFileStream does not understand fileInObjectAndCodeForProject (but MultiByteBinaryOrTextStream does) we get a crash.
Additional Information
Attached Files  SqueakDebug.log [^] (4,466 bytes) 11-08-05 03:08

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0001028closed ohshima m17n: attempting to read a jpeg fails because a MultiByteFileStream is not the thing to use 
related to 0001479closed gokr [BUG] Criticl MultiByteFileStream and StandardFileStream in 3.8g 

- Notes
(0003046 - 141 - 141 - 141 - 141 - 141 - 141)
tim
11-08-05 03:09

I set the priority to high because this seems like something a lot of squeaklanders might hitwhen attempting to share a morph around a class.
 
(0003047 - 113 - 113 - 113 - 113 - 113 - 113)
tim
11-08-05 03:10

Yoshiki, since you are the last person to touch all the involved methods you might have some ideas on fixing this
 
(0004622 - 19 - 19 - 19 - 19 - 19 - 19)
MarcusDenker
03-29-06 23:53

unable to reproduce
 

- Issue History
Date Modified Username Field Change
11-08-05 03:08 tim New Issue
11-08-05 03:08 tim File Added: SqueakDebug.log
11-08-05 03:08 tim Relationship added related to 0001028
11-08-05 03:08 tim Relationship added related to 0001479
11-08-05 03:09 tim Note Added: 0003046
11-08-05 03:10 tim Note Added: 0003047
11-08-05 03:10 tim Assigned To  => ohshima
11-08-05 03:10 tim Status new => feedback
03-29-06 23:53 MarcusDenker Status feedback => closed
03-29-06 23:53 MarcusDenker Note Added: 0004622
03-29-06 23:53 MarcusDenker Resolution open => unable to reproduce
03-29-06 23:53 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
58 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker