Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002247 [Squeak] Any minor always 11-20-05 21:31 11-21-05 18:55
Reporter renggli View Status public  
Assigned To KenCausey
Priority normal Resolution duplicate  
Status closed   Product Version 3.8
Summary 0002247: Evaluating code and #DoIt/#DoItIn:
Description Evaluating code might leave a method #DoIt/#DoItIn: within the receiver class, this is not only annoying for all the tools that have to check the presence of such a method but might also confuse beginners that don't know where this method is coming from.

Since the possibility to execute compiled methods within a receiver without actually adding them to a class is possible in Squeak, the attached change-set makes use of the feature. This does not create a method called #DoIt/#DoItIn: and is about twice as fast as the old approach.
Additional Information See the thread in the mailing-list: "What is this DoItIn: method on my class?"

For a next step we should work trough all the tools in Squeak to remove all the unnecessary checks for #DoIt/#DoItIn:
Attached Files  Compiler-evaluateintonotifyingifFaillogged.st [^] (1,470 bytes) 11-20-05 21:31

- Relationships
duplicate of 0002246closed  Evaluating code and #DoIt/#DoItIn: 

- Notes
(0003126 - 16 - 16 - 16 - 101 - 101 - 101)
KenCausey
11-21-05 18:55

Duplicated 0002246
 

- Issue History
Date Modified Username Field Change
11-20-05 21:31 renggli New Issue
11-20-05 21:31 renggli Status new => assigned
11-20-05 21:31 renggli Assigned To  => KenCausey
11-20-05 21:31 renggli File Added: Compiler-evaluateintonotifyingifFaillogged.st
11-20-05 21:32 renggli Issue Monitored: renggli
11-21-05 18:55 KenCausey Relationship added duplicate of 0002246
11-21-05 18:55 KenCausey Status assigned => closed
11-21-05 18:55 KenCausey Note Added: 0003126
11-21-05 18:55 KenCausey Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker