Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002254 [Squeak] Kernel major always 11-21-05 17:53 01-18-06 23:55
Reporter renggli View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.7
Summary 0002254: Characters are improperly stored (#storeOn:)
Description This change-set makes the printing of characters much nicer. As well it fixes some very strange bugs with other system such as the Refactoring Browser and SmaCC that rely on the fact when storing special characters (such as Character lf, Character cf) in the source-code this is preserved. The old implementation could not satisfy this requirement since Monticello converts all special characters in Squeak line-endings and therefor destroys some of the character literals. This fix not only makes the output of #storeOn: and #printOn: easier to read, but also more portable. Included are 4 tests.
Additional Information
Attached Files  CharacterFixes.1.cs [^] (4,332 bytes) 11-21-05 17:53

- Relationships

- Notes
(0003544 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
01-18-06 23:55

allready in 3.9
 

- Issue History
Date Modified Username Field Change
11-21-05 17:53 renggli New Issue
11-21-05 17:53 renggli File Added: CharacterFixes.1.cs
11-21-05 18:45 renggli Issue Monitored: renggli
12-10-05 15:31 pmm Issue Monitored: pmm
01-18-06 23:55 MarcusDenker Status new => closed
01-18-06 23:55 MarcusDenker Note Added: 0003544
01-18-06 23:55 MarcusDenker Resolution open => fixed
01-18-06 23:55 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
42 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker