Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002271 [Squeak] Morphic minor always 11-28-05 15:08 01-14-06 00:34
Reporter edgardec View Status public  
Assigned To cdegroot
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002271: [BUG] [FIX] Changing system font in 3.9
Description I refile the missing methods, as Paul confirmed what this fix solve the problem
Additional Information Hi, all,

I noticed that since image 6703 it is not possible to change the default
text font without an error and the disappearance of the TOOLS flap.

Just try it:

appearance
standard system fonts
default text font
change to the same as it was (!)
some seconds later there is a walkback.

Any ideas?

Cheers,

Paul Provoost
The Netherlands
Attached Files  SyntaxErrormissingMethods.1.cs [^] (736 bytes) 11-28-05 15:08
 ParserAtInReferenceFix-klc.1.cs.gz [^] (437 bytes) 11-29-05 01:11

- Relationships
has duplicate 0002272closed  [BUG]SyntaxErrorNotification class(Object)>>doesNotUnderstand: #inClass:withCode:doitFlag: 

- Notes
(0003153 - 576 - 600 - 600 - 747 - 747 - 747)
KenCausey
11-29-05 00:29

Good job Edgar, this does indeed appear to fix the problem. It does this by adding 2 simple missing methods. However I wonder if maybe this shouldn't have been fixed by instead changing the reference. Especially if there is only one place referencing this.

In the future please always gzip (compress) your .cs files before uploading them. Unfortunately the .cs extension is also used by C# and on some platforms I fear that the line ending format may be changed if it decides to treat these as ASCII text files.

Note this also resolves 0002272 which is the same issue.
 
(0003155 - 486 - 522 - 522 - 522 - 522 - 522)
KenCausey
11-29-05 00:52

OK, I'm not so certain that this is a good fix after I examine it more closely.

First of all the instance method #setClass:code:debugger:doitFlag: added here refers to a non-existence instance variable called #debugger and does not update the definition to add it.

It looks like this has been refactored to use ToolSet to pick the debugger rather than it be specified. This let's it be switched out much more easily.

I'll attach my own suggested fix for this in a few minutes.
 
(0003156 - 171 - 171 - 171 - 171 - 171 - 171)
KenCausey
11-29-05 01:12

Please note that ParserAtInReferenceFix-klc.1.cs.gz is my preferred fix over the previous SyntaxErrormissingMethods.1.cs. The problem was a missed ToolSet related update.
 
(0003230 - 18 - 18 - 18 - 18 - 18 - 18)
cdegroot
12-08-05 19:42

Harvested to inbox
 
(0003232 - 602 - 626 - 626 - 626 - 626 - 626)
KenCausey
12-08-05 20:18

Speaking of process... ;)

I would really like to keep seperate track of when a team accepts a fix and submits it to the release team and then when the fix is actually included in a released public update and/or image. To that goal I think it would be best if this issue had not been closed at this stage but instead marked 'resolved'. Of course that requires someone to come back and mark the issue closed when it is truly and finally harvested.

This may sound like a pain in the ass but I think it's important. Fixes have been accepted in the past and then dropped and not appear in an image.
 
(0003484 - 45 - 69 - 69 - 69 - 69 - 69)
ducasse
01-14-06 00:02

in 6709 :)
script 20
Compiler-sd.24

Stef
 
(0003485 - 46 - 58 - 58 - 58 - 58 - 58)
KenCausey
01-14-06 00:34

Thank you Stef, I really appreciate it.

Ken
 
(0003486 - 58 - 58 - 58 - 58 - 58 - 58)
KenCausey
01-14-06 00:34

And since this is now in a public update it can be closed.
 

- Issue History
Date Modified Username Field Change
11-28-05 15:08 edgardec New Issue
11-28-05 15:08 edgardec File Added: SyntaxErrormissingMethods.1.cs
11-28-05 20:33 KenCausey Relationship added has duplicate 0002272
11-29-05 00:29 KenCausey Note Added: 0003153
11-29-05 00:52 KenCausey Note Added: 0003155
11-29-05 01:11 KenCausey File Added: ParserAtInReferenceFix-klc.1.cs.gz
11-29-05 01:12 KenCausey Note Added: 0003156
11-29-05 23:40 KenCausey Status new => assigned
11-29-05 23:40 KenCausey Assigned To  => cdegroot
12-08-05 19:42 cdegroot Status assigned => closed
12-08-05 19:42 cdegroot Note Added: 0003230
12-08-05 19:42 cdegroot Resolution open => fixed
12-08-05 19:42 cdegroot Fixed in Version  => 3.9
12-08-05 20:18 KenCausey Note Added: 0003232
01-14-06 00:02 ducasse Status closed => resolved
01-14-06 00:02 ducasse Note Added: 0003484
01-14-06 00:34 KenCausey Note Added: 0003485
01-14-06 00:34 KenCausey Status resolved => closed
01-14-06 00:34 KenCausey Note Added: 0003486


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
79 total queries executed.
50 unique queries executed.
Powered by Mantis Bugtracker