Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002352 [Squeak] Morphic minor always 12-12-05 10:29 02-24-06 21:51
Reporter al View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002352: FileListBrowser shows "changes" and "code" buttons twice
Description FileListBrowser, when pointed to a smalltalk code file, shows the "changes" and "code" buttons twice
Additional Information
Attached Files

- Relationships

- Notes
(0003296 - 196 - 230 - 230 - 230 - 230 - 230)
tbn
12-12-05 21:30

Putting a halt into FileList2#updateButtonRow and inspecting
"self dynamicButtonServices" shows that ChangeSet and ChangeSorter
have registered for handling code files.

We should remove one.
 
(0003297 - 325 - 355 - 355 - 355 - 355 - 355)
tbn
12-12-05 21:53

Squeak 3.8#6665 looks ok, the bug is in 3.9#6705.

Looks like Andreas Raab (ar) moved class side code from ChangeSet to ChangeSorter. The old code (including file service registration) is still in ChangeSorter.
Either he forgot to remove it or is in the midst of a bigger refactoring.

I write him an e-mail to comment.
 
(0003298 - 102 - 102 - 102 - 102 - 102 - 102)
andreas
12-12-05 22:24

The problem is caused by installing two tool sets (duplicate services). Remove one and you'll be fine.
 
(0003309 - 233 - 283 - 283 - 283 - 283 - 283)
andreas
12-13-05 02:10

Actually, it might be good to implement the #services of the various tools depending on which tool set is installed, e.g., something like:

ChangeListPlus>>services
  ToolSet default == PlusTools ifFalse:[^#()].
  ... yaddaya ...
 
(0004067 - 13 - 13 - 13 - 13 - 13 - 13)
MarcusDenker
02-24-06 21:51

fixed in 7003
 

- Issue History
Date Modified Username Field Change
12-12-05 10:29 al New Issue
12-12-05 21:30 tbn Note Added: 0003296
12-12-05 21:53 tbn Note Added: 0003297
12-12-05 22:24 andreas Note Added: 0003298
12-13-05 02:10 andreas Note Added: 0003309
02-24-06 21:51 MarcusDenker Status new => closed
02-24-06 21:51 MarcusDenker Note Added: 0004067
02-24-06 21:51 MarcusDenker Resolution open => fixed
02-24-06 21:51 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker