Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002446 [Squeak] Any minor always 01-04-06 03:28 09-08-08 15:26
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002446: Character nonbreaking space does not look like a space
Description for this one
In a workspace type,select and print-It

Character nbsp "(defined as 202 in ascii) "

The nonbreaking space should display as a space.
On my computer I get a circumflexed capital E. in the default font and in others that sampled.
Additional Information This recently became interesting because iVar menu was reimplemented to separate words into separate menu items. On lists of more than 6 ivars it would offer 'show alphabetically' which would be broken at the space. I proposed a fix by simply uniting the two words with an underscore and noted that a non-breaking space would be an even more elegant solution.

Following up on that thought only discovered another bug.

Why do the fonts store the wrong character at this location?
 
Attached Files  Character class-nbsp.st [^] (271 bytes) 04-10-06 02:29

- Relationships
child of 0006392closed  (Character nbsp) is not the non breaking space character 

- Notes
(0003423 - 885 - 994 - 1128 - 1128 - 1128 - 1128)
andreas
01-04-06 03:41
edited on: 01-04-06 03:41

Heh. This is funny for at least two reasons. First is that I always thought ASCII is seven bit, not eight, so using 202 seems ... err ... odd to say the least ;-) Second, regardless of where this definition comes from it clearly originates from the times where we used to use Mac Roman encoding so either the comment or the value must have been wrong to begin with (hah!).

One thing's for sure: If we look at the Latin1 definition ( http://www.w3.org/MarkUp/html3/latin1.html [^] ) we see that:

&202; Capital E, circumflex accent

which is exactly what we observe. So the it isn't the display that's wrong, it's the constant.

Oh, and did I mention that because Character is not in one of the font classes I won't fix broken constants over there? ;-) Therefore:

Status -> new
Category -> any
Assigned To -> nobody

Please reassign to the proper maintainer.

 
(0003426 - 977 - 1113 - 1113 - 1113 - 1113 - 1113)
wiz
01-05-06 03:35

Hi Andreas,

As comedian Red Skeleton used to say:

"I don't make'em. I just tell 'em."

After posting this I did some more checking.

The font atlantis does have a nbsp that becomes a space.

And my ascii font in Tex-edit encodes 202 as a nbs as well. Mac and browsers disagree on several other constants as well so It be nice if some one knowledgable would chime in on what the constant should be and under what circumstances.

I just look at the latin1.html you referenced. Latin1 does not have a non-breaking space. So that pretty much puts paid to the possibility of finding it in a latin1 font set. Ah well. At least squeak has now freed up the underscore to be an underscore.


Thanks for you help Andreas. Informative as always.


Proposed resolution. The cross platform priority rules out the use of nbsp in any string that might espect to be represented in a latin1 font.

q: Should Character class>>nbsp be removed as a character constant ?
 
(0004720 - 162 - 186 - 186 - 186 - 186 - 186)
wiz
04-10-06 02:32

Character class-nbsp.st updates nbsp to latin1 encoding common usage. (char 160).

With enough time illumination happens.

Yours in service, -- Jerome Peace.
 
(0010492 - 248 - 272 - 502 - 502 - 502 - 502)
nicolas cellier
04-02-07 21:43

16rA0 is officially the codePoint of non breaking space character according to ISO/IEC-10646 universal character set.

http://standards.iso.org/ittf/PubliclyAvailableStandards/c039921_ISO_IEC_10646_2003(E).zip [^]

Please include this fix in image.
 
(0010496 - 83 - 89 - 89 - 89 - 89 - 89)
edgardec
04-05-07 14:12

This now is 7078fixCharacter class-nbsp.cs and was in updates for 3.10
Thanks all!
 
(0012590 - 30 - 30 - 30 - 30 - 30 - 30)
KenCausey
09-08-08 15:26

Update 7078, shipped with 3.10
 

- Issue History
Date Modified Username Field Change
01-04-06 03:28 wiz New Issue
01-04-06 03:28 wiz Status new => assigned
01-04-06 03:28 wiz Assigned To  => andreas
01-04-06 03:41 andreas Note Added: 0003423
01-04-06 03:41 andreas Assigned To andreas =>
01-04-06 03:41 andreas Status assigned => new
01-04-06 03:41 andreas Category Fonts => Any
01-04-06 03:41 andreas Note Edited: 0003423
01-05-06 03:35 wiz Note Added: 0003426
01-07-06 14:04 pmm Issue Monitored: pmm
04-10-06 02:29 wiz File Added: Character class-nbsp.st
04-10-06 02:32 wiz Note Added: 0004720
03-30-07 22:51 wiz Relationship added child of 0006392
04-02-07 21:43 nicolas cellier Note Added: 0010492
04-05-07 14:12 edgardec Note Added: 0010496
07-28-07 23:10 wiz Status new => resolved
07-28-07 23:10 wiz Resolution open => fixed
07-28-07 23:10 wiz Fixed in Version  => 3.10
09-08-08 15:26 KenCausey Status resolved => closed
09-08-08 15:26 KenCausey Note Added: 0012590


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
77 total queries executed.
48 unique queries executed.
Powered by Mantis Bugtracker