Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002452 [Squeak] Tools minor always 01-07-06 03:21 02-27-06 23:46
Reporter wiz View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002452: For double clicking on entrys to work properly, Inspectors and Browsers must explicitly disable autodeselect.
Description The fix for Mantis 0001347: Doubleclick on list entries not working properly

has two parts to it.

The first is correcting the logic in PLM (Plugalbe List Morph)>>mouseUp: .

The second is that once this as done the users of PLM that want double click to work must disable the autodeselect feature by explicitly setting the boolean to false.

Additional Information The mouseUp: fix has been approved by the Morphic team.
The patches to Inspectors and Browsers need to be approved by the Tools team.

The suggested fix has been uploaded to Manits 0001347 as IB3-8DClickFix-wiz.5.cs.gz which is the combination of the two changesets above it.

Please apporve and integrate the patches to disable autodeselect into your Browser and Inspector tools.

If you know of more places to fix that would be good too.

Yours in service, -- (wiz) Jerome Peace
Attached Files  AutoDeselectToolFixes-wiz.3.cs [^] (4,984 bytes) 02-26-06 06:24

- Relationships
related to 0007096new  PluggableListMorph>>mouseUp: sets index to 0 

- Notes
(0004107 - 371 - 401 - 401 - 401 - 401 - 401)
wiz
02-26-06 06:33

AutoDeselectToolFixes-wiz.3.cs

Adds autoDeselect: false. to 4 tool methods. The patches come just after the methods setup doubleClick selectors. This is appropriate because doubleClicking will suppose that the item in question will still be selected.
So this should complete the fix started in the fix started in the other report.

Yours in service, -- Jerome Peace
 
(0004174 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
02-27-06 23:46

7004
 

- Issue History
Date Modified Username Field Change
01-07-06 03:21 wiz New Issue
02-26-06 06:24 wiz File Added: AutoDeselectToolFixes-wiz.3.cs
02-26-06 06:33 wiz Note Added: 0004107
02-26-06 20:15 MarcusDenker Status new => resolved
02-26-06 20:15 MarcusDenker Fixed in Version  => 3.9
02-26-06 20:15 MarcusDenker Resolution open => fixed
02-26-06 20:15 MarcusDenker Assigned To  => MarcusDenker
02-27-06 23:46 MarcusDenker Status resolved => closed
02-27-06 23:46 MarcusDenker Note Added: 0004174
06-18-08 00:05 wiz Relationship added related to 0007096


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker