Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002498 [Squeak] Tools major always 01-16-06 07:33 02-15-06 17:29
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version
Summary 0002498: In Sq6713 Strange behaviours when asking for class ref.
Description For this one.

In a fresh 6713 image.
get a workspace.
type "setTarget:"
select and request implementors. (when it asks for tool set say standard)



Having noted that select a class (e.g. BalloonMorph) and request class refs.

In addition to other classes which reference BalloonMorph by name in the code or the comments you get several balloom morph methods ( I counted 8 out of 13) which don't seem to have a reason for being there.

As you select them the code pane will flash black before switching text. (the show damage preference is NOT set in case you are wondering).

This flashing only happens with the methods that should not really be there. As if the browser knows something is wrong.
Additional Information I haven't looked furthur into it than this. But I figured it should be reported early before too many other symtoms obscure the cause.

I could not figure out a rhyme or reason why some of the 13 methods were shown but not others.
Attached Files  fixClassRefs-md.1.cs [^] (1,292 bytes) 02-15-06 11:09

- Relationships

- Notes
(0003862 - 277 - 319 - 319 - 319 - 319 - 319)
MarcusDenker
02-15-06 11:09

attached is a fix.

backround: in 3.9, all methods now have the classbinding in the last literal. That used to be
only super method. Thus the #sendsToSuper check in the method

whichSelectorsReferTo: literal special: specialFlag byte: specialByte

needed to be removed.
 
(0003866 - 12 - 12 - 12 - 12 - 12 - 12)
MarcusDenker
02-15-06 17:29

fixed in 3.9
 

- Issue History
Date Modified Username Field Change
01-16-06 07:33 wiz New Issue
02-15-06 11:09 MarcusDenker Note Added: 0003862
02-15-06 11:09 MarcusDenker File Added: fixClassRefs-md.1.cs
02-15-06 17:29 MarcusDenker Status new => closed
02-15-06 17:29 MarcusDenker Note Added: 0003866
02-15-06 17:29 MarcusDenker Resolution open => fixed
02-15-06 17:29 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
41 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker