Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002512 [Squeak] Morphic major always 01-16-06 21:40 03-19-06 13:57
Reporter wiz View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002512: In 6713 Morphs dropped onto their viewers get deleted.
Description For this one.

Get an object (a polygon will do nicely.)

Using the halos open a veiwer for the polygon.

With the hand pick up the polygon.
 Move it over the viewer.
   And dropit.

Rather than returning to its spot it will disappear and so will its viewer.
Additional Information This is just a flashier demonstration of the bug reported in Mantis 0001816.

The preferences have been set in 6713 to delete the morph w/o putting it in the trash.

Since a morph in the hand no longer remembers its former owner it will not return but be deleted instead.
Attached Files  RejectedPolyDeleteFix-wiz.1.cs [^] (1,335 bytes) 01-25-06 05:18
 polygonFix-tak.cs [^] (1,634 bytes) 03-17-06 17:51

- Relationships
related to 0001816closed  In 6690 morphs dropped onto objects window get a one way trip to the trash. 

- Notes
(0003599 - 722 - 806 - 806 - 806 - 806 - 806)
wiz
01-23-06 06:43
edited on: 01-23-06 06:52

Another clue:

Polygons get deleted but RectangeMorphs and EllipseMorphs happliy return to their former position. I guess some morphs just take rejection better than others.

I'm now playing in Sq6717 but I don't think thats significant.

I know Polygons used to know what to do when rejected back in Sq 3.2 because I made puzzleboard there using polygons for piece and they worked fine.

Now I suspect grabing the polygon is not recording its former owner.
What's changed?

I check in 3.8from3.0 there everything worked as planed polygons and ellipses both return to former positions when rejected.
In 3.9from3.0 polygons got trashed when rejected. So the breakage is do to 3.8 development. I wonder where.

 
(0003625 - 617 - 700 - 700 - 700 - 700 - 700)
wiz
01-25-06 05:25

Found the problem.

From the preamble.

Polygons releaseCacheState whenever they change position.
The overide calls its super and the super(Morph) was changed in

 tak 1/12/2005 14:57 caching only in change set 6580changesFromSql38ToJa

While it might be wiser to make polygon cleverer because of the severity of the problem it seems fair to revert the fix until more thought can be put into polygon. I don't know what problem the original patch was suppose to solve.

So this and the previously reported bug 1816 are actually the same and this will remedy both.

Yours in service, -- Jerome Peace
 
(0004514 - 323 - 323 - 323 - 323 - 323 - 323)
tak
03-17-06 17:57

Surely, this bug is caused from my misunderstanding of Morphic. Proposed change set polygonFix-tak.cs fixes will solve the issue. Originally, my patch was for eliminating unexpected pointer when a project or a morph is saved into .pr or .morph file. Andreas Raab suggested me that #prepareToBeSaved is right place to do it.
 
(0004518 - 292 - 328 - 328 - 328 - 328 - 328)
wiz
03-19-06 00:01

Hi tak,

Thanks for your help and quick response. I looked a your changes and they should do the trick.

I tested to make sure polygons no longer get deleted (they don't). I didn't test the other aspect with change sets. i assume that works to your satisfaction.

Cheers -- Jerome Peace
 
(0004519 - 183 - 207 - 207 - 207 - 207 - 207)
wiz
03-19-06 00:05

Reminder sent to: user457

Hi Jaun,

This ones ready to go into an image. taks fix will work. If you are still busy with your move I suspect you can just ask Marcus to handle it.

Marcus will fix anything.
 
(0004524 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
03-19-06 13:57

will be in 7013
 

- Issue History
Date Modified Username Field Change
01-16-06 21:40 wiz New Issue
01-19-06 11:05 MarcusDenker Relationship added related to 0001816
01-23-06 06:43 wiz Note Added: 0003599
01-23-06 06:52 wiz Note Edited: 0003599
01-25-06 05:18 wiz File Added: RejectedPolyDeleteFix-wiz.1.cs
01-25-06 05:25 wiz Note Added: 0003625
03-08-06 21:16 cdan Issue Monitored: cdan
03-17-06 17:51 tak File Added: polygonFix-tak.cs
03-17-06 17:57 tak Note Added: 0004514
03-19-06 00:01 wiz Note Added: 0004518
03-19-06 00:05 wiz Issue Monitored: user457
03-19-06 00:05 wiz Note Added: 0004519
03-19-06 13:57 MarcusDenker Status new => closed
03-19-06 13:57 MarcusDenker Note Added: 0004524
03-19-06 13:57 MarcusDenker Resolution open => fixed
03-19-06 13:57 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
76 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker