Mantis Bugtracker
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002514 [Squeak] Kernel minor always 01-16-06 22:14 01-19-06 10:45
Reporter bert View Status public  
Assigned To
Priority normal Resolution fixed  
Status closed   Product Version 3.9
Summary 0002514: [FIX] condenseSources (was: Re: [Q] Removing changes file content.)
Description You should have at most two versions, one in the sources file and one
in the changes file. If you have more, then condenseChanges did not
work properly.

One particular thing that breaks when running condenseChanges is
overrides, which relies on the method history in the changes file.

Attached is a fix for that, it preserves method histories for methods
in a "*-override" category. It's pretty dumb, retaining each and
every version of that method. An improvement would be to only keep
the necessary ones, that is, those most recent after the
categorization changed. But it works ;-)

- Bert -

Am 16.01.2006 um 04:10 schrieb Sungjin Chun:

> Even though after running condenseChanges, I do have multiple
> versions of some method. (I can see this with VersionBrowser).
> Thanks anyway. I'll try more.
>
> On Jan 16, 2006, at 2:24 AM, Lukas Renggli wrote:
>
>>> I might have done something wrong, but after condenseChanges and
>>> condenseSources the size of sources file increased as much as
>>> changes
>>> file. Yes, the changes file is 4k now but total size is not
>>> decreased.
>>
>> #condenseChanges just removes the version history from the
>> changes-file, so if you have accepted the same method twice it just
>> keeps the last version. This should decrease the size of your
>> changes-file.
>>
>> #condenseSources is something completely different. I guess there is
>> no reason that someone wants to do this on its own, unless they are
>> releasing Squeak 4.0, that (probably) will be shipped with a new
>> source-file. This will not change the total size of the changes- plus
>> the sources-file, as the changes will be moved to the source.
>>
>> I am not sure, if everything I wrote here is correct, this is just
>> what I think these methods do. I need to do a #condenseChanges from
>> time to time to reduce the size of the changes-file, because it
>> reaches its limits; but I've never done a #condenseSources.
>>
>> Lukas
Additional Information
Attached Files  ClassDescription-fileOutChangedMessagesonmoveSourcetoFile.st.gz [^] (601 bytes) 01-16-06 22:14

- Relationships
related to 0005783new  [RFI] Needed a way to condense sources/changes that preserves version trails better. 

- Notes
(0003553 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
01-19-06 10:45

will be in 6716
 

- Issue History
Date Modified Username Field Change
01-16-06 22:14 KenCausey New Issue
01-16-06 22:14 KenCausey File Added: ClassDescription-fileOutChangedMessagesonmoveSourcetoFile.st.gz
01-16-06 22:15 KenCausey Reporter KenCausey => bert
01-19-06 10:45 MarcusDenker Status new => closed
01-19-06 10:45 MarcusDenker Note Added: 0003553
01-19-06 10:45 MarcusDenker Resolution open => fixed
04-27-09 15:14 Keith_Hodges Relationship added related to 0005783


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker